Py||Big Dipper

题目描述
The Big Dipper number is a 7-digit number, which equals to the sum of every digit’s 7 powers.

For example:
1741725 is a Big Dipper number because of:

17+77+47+17+77+27+5^7=1741725

Please write a program to determine whether a positive integer is a Big Dipper number.

输入
Input includes multiple rows of data, one positive integer per line.
输出
For each input, if it is a Big Dipper number, output Y, otherwise output N.
样例输入 Copy
1741725
1111111
样例输出 Copy
Y
N

while True:
    k=int(input())
    n=k
    s=0
    su=0
    for i in range(7):
        s=n%10
        su=su+s**7
        n=n//10
    if su==k:
        print('Y')
    else:
        print('N')
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值