Py||Full Permutation

题目描述
Write a program to list all the permutations that can be formed by N integers from 1 to N, and output them in lexicographic order.

For example, given an integer N = 2,
the permutations are:
1 2
2 1
输入
The input is a set of integers, each line is an integer N, N < 8, and the last line is 0.
输出
For each input N, all the permutations of 1 to N are output in lexicographic order,

the numbers are separated by spaces, and the output of each permutation is in one line.
样例输入 Copy
2
3
0
样例输出 Copy
1 2
2 1
1 2 3
1 3 2
2 1 3
2 3 1
3 1 2
3 2 1

import itertools
while True:
    n=int(input())
    s=[]
    for i in range(1,n+1):
        s.append(i)
    list2=list(itertools.permutations(s,n))
    for i in list2:
        print(*i)
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值