POJ 3636 Nested Dolls

Nested Dolls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7861 Accepted: 2134

Description

Dilworth is the world's most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and heighth= if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?

Input

On the first line of input is a single positive integer 1 ≤ t ≤ 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 ≤m ≤ 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integersw1, h1,w2, h2, ... ,wm,hm, where wi is the width and hi is the height of doll numberi. 1 ≤ wi, hi ≤ 10000 for all i.

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible.

Sample Input

4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51

Sample Output

1
2
3
2

Source


解析

动规。跟导弹拦截一样的题。

w从小到大,w相等的h从大到小排个序。然后求h最大非升子序列。

理论:

偏序集的两个定理:

     定理1>令(X,≤)是一个有限偏序集,并令r是其最大链的大小,则X可以被划分成r个但不能再少的反链。
                     其对偶定理称为Dilworth定理:
      定理2>令(X,≤)是一个有限偏序集,并令m是反链的最大的大小,则X可以被划分成m个但不能再少的链。
   最后:链的最少划分数=反链的最长长度。求反链的最大长度就可以了,谁让它们等价呢?!
      现在又有一个问题:为何求出的最长不递增子序列的长度就是反链的最大长度呢?其实w是符合条件的,不妙的是h互不配合!对于该反链的任意两个盒子,总有:w1<=w2,但h1>h2 (或w1<w2,但h1=>h2,两个=不能同时成立,没有完全相同的盒子),固执地符合反链的条件!没办法,天意啊!  

http://www.docin.com/p-324343046.html

http://www.cnblogs.com/yueshuqiao/archive/2011/08/21/2147782.html

LIS O(nlogn)算法讲解

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstring>

using namespace std;

struct node
{
	int x,y;
	bool operator<(const node &a) const//以x为关键y为次关键字排序
	{
		if(x==a.x) return y>a.y;//y降序
		return x<a.x;//x升序
	}//iff a.s<b.s && a.b<b.b
} p[20100];

int N,dp[20100],g[20100];
//dp[i]表示以第i个人结尾的上升子序列长度
//g[i]表示序列长度为i的序列最小以g[i]为b
void readdata()
{
	scanf("%d",&N);
	for(int i=1;i<=N;i++) 
		scanf("%d%d",&p[i].x,&p[i].y);
	p[N+1].x=0x3f3f3f3f;p[N+1].y=0;
	sort(p+1,p+1+N+1);
	//for(int i=1;i<=N+1;i++) printf("%d ",p[i].y);printf("\n");
}
void dynamic_planning()
{
	memset(g,0x3f,sizeof(g[0])*(N+3));
	for(int i=1;i<=N+1;i++)
	{
		int k=upper_bound(g+1,g+1+N+1,-p[i].y)-g;
		dp[i]=k;
		g[k]=-p[i].y;
	}

	printf("%d\n",dp[N+1]-1);
}
int main()
{
	int T; scanf("%d",&T);
	for(int i=1;i<=T;i++)
	{
		readdata();
		dynamic_planning();
	}	
	while(1);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值