CDOJ 1114 Cent Savings

Cent Savings

Time Limit: 6000/2000MS (Java/Others)     Memory Limit: 262144/262144KB (Java/Others)
 

title

To host a regional contest like NWERC a lot of preparation is necessary: organizing rooms and computers, making a good problem set, inviting contestants, designing T-shirts, booking hotel rooms and so on. I am responsible for going shopping in the supermarket.

When I get to the cash register, I put all my n items on the conveyor belt and wait until all the other customers in the queue in front of me are served. While waiting, I realize that this supermarket recently started to round the total price of a purchase to the nearest multiple of 10 cents (with 5 cents being rounded upwards). For example, 94 cents are rounded to 90 cents, while 95 are rounded to 100.

It is possible to divide my purchase into groups and to pay for the parts separately. I managed to find d dividers to divide my purchase in up to d+1 groups. I wonder where to place the dividers to minimize the total cost of my purchase. As I am running out of time, I do not want to rearrange items on the belt.

Input

The input consists of:

one line with two integers n  (1n2000)  and d  (1d20) , the number of items and the number of available dividers;
one line with n integers p1,… pn  (1pi10000  for  1in) , the prices of the items in cents. The prices are given in the same order as the items appear on the belt.

Output

Output the minimum amount of money needed to buy all the items, using up to d dividers.

Sample input and output

Sample Input Sample Output
5 1
13 21 55 60 42
190
5 2
1 1 1 1 1
0

Source

2015 UESTC ACM Summer Training Team Selection (3)

解析
区间dp
dp[i][j]表示 已经前i个物品用了j个 dividers付的钱。但是第i个物品后是没有dividers的。所以实际付的钱是((dp[i][j]+5)/10)*10.
每用一个divider 都要对前面的东西结账。于是dp[i][j]= ((dp[i-1][j-1]+5)/10)*10+p[i]
如果没有使用 dividers就是dp[i][j]=dp[i-1][j]+p[i]
解释的不是很清楚……反正就是一个挺奇怪的区间dp,好好体会一下。
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

#define INF 0x3f3f3f3f
int dp[2010][25],p[2010],N,D;
/*
int min(int a,int b,int c)
{
	if(a>=b && a>=c) return a;
	if(b>=a && b>=c) return b;
	if(c>=a && c>=b) return c;
}
*/
int main()
{
	scanf("%d%d\n",&N,&D);
	memset(dp,0x3f,sizeof(dp));
	for(int i=1;i<=N;i++)
	{
		scanf("%d",&p[i]);
		dp[i][0]=p[i];
		if(i>1) dp[i][0]+=dp[i-1][0];
	}

	for(int j=1;j<=D;j++)
		for(int i=1;i<=N;i++)
		{
			if(dp[i-1][j-1]!=INF)
				dp[i][j]=min(((dp[i-1][j-1]+5)/10)*10+p[i],dp[i][j]);
			if(dp[i-1][j]!=INF)
				dp[i][j]=min(dp[i-1][j]+p[i],dp[i][j]);
		}
	/*
	for(int i=1;i<=N;i++)
	{
		for(int j=0;j<=D;j++) printf("%d ",dp[i][j]);
		printf("\n");
	}
	*/

	int ans=0X3f3f3f3f;
	for(int i=0;i<=D;i++)
		ans=min(((dp[N][i]+5)/10)*10,ans);
	printf("%d\n",ans);
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值