Description
Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.
Your job is to find out the minimum time the player should spend to win the game.
Input
There are multiple test cases.
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.
Output
Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.
Sample Input
1 1 1 1 2 10 1 1 2 5 3 100 1 10 3 20 10 100
Sample Output
2 4 5
动态规划。不过这个题的思考方式比较特殊……
dp[i]表示时间i能造成的最大伤害。
那里的dp转移方程看起来很奇怪,其实它是从0开始造i船,其他的造船计划全部向后推迟T[i]
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int T[34],l[34],N,L,dp[334];
int main()
{
int i,j;
while(scanf("%d%d",&N,&L)==2)
{
for(i=1;i<=N;i++)
scanf("%d%d",&T[i],&l[i]);
memset(dp,0,sizeof(dp));
for(j=1;j<=L;j++)
for(i=1;i<=N;i++)
dp[j+T[i]]=max(dp[j]+l[i]*j,dp[j+T[i]]);
for(i=1;i<=330;i++)
if(dp[i]>=L) break;
printf("%d\n",i);
}
return 0;
}