《动态规划》— ZOJ 3623 Battle Ships(完全背包)

 

Battle Ships


Time Limit: 2 Seconds      Memory Limit: 65536 KB


 

Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 
The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines, each line contains two integers t i(1 ≤ t i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5

 

/*
	Name: ZOJ 3623 Battle Ships   
	Author: Liujiuxiaoshitou
	Date: 15/04/17 19:14
	Description:   动态规划   完全背包 
*/
//dp[i]代表时间为i时最多可以打掉的血然后找到第一个dp[i]>=L,那么就是最短的时间采用的是用当前状态去更新后面状态对于,j+T[i]时间段内,dp[j]更新dp[j+T[i]],表示一开始的T[i]秒是在建武器ij的时间段内武器i一直都在工作,然后J时间段内套用j+T[i]时间段内的含义.所以该动规方法是可行的
#include<stdio.h>
#include<string.h>
#include <algorithm>
using namespace std;

int N,L;  // Battle Ships的数量   L为防御塔的寿命
int T[35],l[35], dp[335];

int main()
{
	while(scanf("%d%d",&N,&L)!=EOF)
	{
		int i,j;
		for(i = 1; i <= N; i++)
		{
			scanf("%d%d",&T[i],&l[i]);
		} 
		memset(dp,0,sizeof(dp));
		
		for(j = 1; j <= L; j++)
		{
			for(i = 1; i <= N; i++)
			{
				dp[j+T[i]] = max(dp[j]+l[i]*j,dp[j+T[i]]);    //状态转移方程 
			}
        }
       
		for(i = 1; i <= 330; i++)
		{
			if(dp[i] >= L)
			{
				
				break;
			}
		}
		printf("%d\n",i);
	} 
    return 0;
} 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值