题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入
5 1 2 4 14 9 3 1 3 2 5 4 1
样例输出
3 10 7
题目解释:
这是一道英文题,他的意思是,第一行输入:第一个数表示有N条路,并在之后给出N个数表示N条道的路径长度,这些路会形成一个环
第二行的输入:需要计算M次给定两个节点之间的最短距离
接下来的M行就是两个节点的序号
如图:(五条路)
从图中可以知道两个节点之间的最短路径只能二选一:(如1 3)顺时针方向走(D1+D2),和逆时针方向走
(D3+D4+D5=sum-D1-D2);然后判断哪个大即可
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
int main() {
int N,M;
scanf("%d",&N);
int dis[N+1]={0};
//用来存储每条边的长度 dis[i]来存储Ni到N(i+1)
int D[N+1]={0};
//D[i]用来存储从N1到Ni的下一个节点的长度(顺时针),
//这样可以存储到整个环的长度 ,如果只是N1到Ni,那么只能存储到N1到N5的距离
int sum=0;
int min=0;//最后的输出
for(int i=1;i<=N;i++){ //i从1开始
scanf("%d",&dis[i]);
sum+=dis[i];
D[i]=sum;
}
scanf("%d",&M);
int a,b;
for(int i=0;i<M;i++){
scanf("%d %d",&a,&b);
//为了避免相减为负数,还要比较大小,令a>b
if(b>a){
int temp=a;
a=b;
b=temp;
}
//
int c1=D[a-1]-D[b-1];
int c2=sum-c1;
min=c1>c2?c2:c1;
printf("%d\n",min);
}
return 0;
}