算法笔记4.1 问题 I: 排名

题目描述

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。

输入

测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。 
当读入的考生人数为0时,输入结束,该场考试不予处理。

输出

对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。

样例输入

3 5 32
17 10 12 9 15
CS22003 5 1 2 3 4 5
CS22004 3 5 1 3
CS22002 2 1 5
0

样例输出

3
CS22003 63
CS22004 44
CS22002 32

提示

 

 


这题比较简单,计算好每个人的分数后按题目要求排序即可。

#include<iostream>
#include<string>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

struct Student{
	char id[21];
	int count;
	int total;
	
}stu[1001];

bool cmp(Student a,Student b){
	if(a.total==b.total){
		return strcmp(a.id,b.id)<0;
	}else{
		return a.total>b.total;
	}
}
int main() {
	
int n,m,g;

scanf("%d",&n);

while(n){
	
	int count=0;
	scanf("%d%d",&m,&g);
	int score[m+10]={0};
	for(int i=1;i<=m;i++){
		scanf("%d",&score[i]);
	}
	
	for(int i=0;i<n;i++){
		int total_score=0;
		scanf("%s %d",stu[i].id,&stu[i].count);
		int compute=0;
		for(int j=0;j<stu[i].count;j++){
			scanf("%d",&compute);
			total_score+=score[compute];
		}
		stu[i].total=total_score;
		if(stu[i].total>=g){
			count++;		
		}
	}
	sort(stu,stu+n,cmp);
	printf("%d\n",count);
	for(int i=0;i<n;i++){
	   if(stu[i].total>=g){
			printf("%s %d\n",stu[i].id,stu[i].total);
			
		}
	
	}
	
scanf("%d",&n);	
}


return 0;	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值