解决maven web项目Cannot change version of project facet Dynamic Web Module错误

版权声明:本文为博主原创文章,欢迎转载,转载请注明作者、原文超链接 https://blog.csdn.net/Lin_xiaofeng/article/details/78803878

创建maven web项目时,修改Dynamic Web Module的版本,会报错如下:


下面我们将解决这个版本不能修改的问题,此例中我要将Dynamic Web Module版本修改为3.1(你也可以修改为你想要的其他版本) 。

首先,打开项目的web.xml文件:




会发现这个catalog比较老,用的servlet还是2.3的。修改如下,保存。


<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
		 xmlns="http://xmlns.jcp.org/xml/ns/javaee" 
		 xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee 
		 http://xmlns.jcp.org/xml/ns/javaee/web-app_3_1.xsd" version="3.1">
		 
   <display-name>Archetype Created Web Application</display-name>  
   
</web-app>

然后去工程文件夹下,打开.settings文件夹,打开org.eclipse.wst.common.project.facet.core.xml 文件:


红圈内即为Dynamic Web Module的版本,这里将其修改为3.1,红圈上面一行是你项目所对应的jdk版本。


修改好后保存,关闭文件。然后再e到clipse中,右击项目 -> Maven -->Update Project,就好了。

可以看到,现在DynamicWeb Module版本已经成功修改为3.1了。




展开阅读全文

没有更多推荐了,返回首页