HDU 6319 Problem A. Ascending Rating 【2018多校3】 单调队列

Problem A. Ascending Rating

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 2101    Accepted Submission(s): 636

 

Problem Description

Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant's QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m, say [l,l+m−1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=−1and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating and count. Please write a program to figure out the answer.

Input

The first line of the input contains an integer T(1≤T≤2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1≤m,k≤n≤107,5≤p,q,r,MOD≤109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD.
In the next line, there are k integers a1,a2,...,ak(0≤ai≤109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<i≤n) are then produced as follows :

ai=(p×ai−1+q×i+r)modMOD
It is guaranteed that ∑n≤7×107 and ∑k≤2×106.

Output

Since the output file may be very large, let's denote maxratingi and counti as the result of interval [i,i+m−1].
For each test case, you need to print a single line containing two integers A and B, where :

AB==∑i=1n−m+1(maxratingi⊕i)∑i=1n−m+1(counti⊕i)
Note that ``⊕'' denotes binary XOR operation. 

Sample Input

1

10 6 10 5 5 5 5

3 2 2 1 5 7 6 8 2 9

Sample Output

46 11

Source

2018 Multi-University Training Contest 3


题意:

给出变量 n,m,k,p,q,r,mod

n 表示有一个总长度为 n 的数列,需要对数列里所有长度为 m 的区间做操作,下面会给出数列的前 k 个数,然后先使用 给出的 p q r mod  和 一个公式先求出这个数列的其他数,公式 ai = ( p * a(i-1) + q * i + r ) % mod

区间按从前往后分,总共会有 n - m + 1 个,每个区间按顺序给一个编号 i  

然后求两个答案,第一个 是第 i 个区间里最大值 与 i 的异或结果的和

第二个是  第 i 个区间里上升序列元素个数 与 i 异或结果的和 (5 1 3 7 9 2 10) 这个区间的上升序列元素个数为 4

(5 1 2 3 4 7 8) 这个区间的上升序列元素个数为 3 ,而不是 4,也就是说第一个元素是必取的

思路:

对于区间最大值,使用单调队列做维护,单调队列里维护一个下降序列,那么队头维护的就是区间的最大值

对于区间上升序列的维护,考虑单调队列的原理,维护的是下降序列,那么如果我们倒过来使用单调队列,就相当于正向构成了一个上升序列,每次队列内剩余元素个数就是上升序列元素个数

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>

using namespace std;
#define ll long long
#define mem(a,x) memset(a,x,sizeof(a))
const int maxn = 1e7 + 5;

int num[maxn],que[maxn],ansA[maxn],ansB[maxn];

/**
* 用正向的单调队列维护区间最大值 
*/
void calculateA(int n,int m){
	int head = 0,rear = 0;
	for(int i = 1;i <= n;i++){
		while(rear > head && num[que[rear - 1]] <= num[i]){
			rear--;
		}
		que[rear++] = i;
		if(i >= m){
			while(que[head] <= i - m){
				head++;
			}
			ansA[i] = num[que[head]];
		}
	}
}

/**
* 用逆向的单调队列维护区间上升序列元素 
*/
void calculateB(int n,int m){
	int head = 0,rear = 0;
	for(int i = n;i >= 1;i--){
		while(rear > head && num[que[rear - 1]] <= num[i]){
			rear--;
		}
		que[rear++] = i;
		if(i <= n - m + 1){
			while(que[head] >= i + m){
				head++;
			}
			ansB[i] = rear - head;
		}
	}
}

int main(){
	int T;
	int n,m,k,p,q,r,mod;
	ll a,b;
	scanf("%d",&T);
	while(T--){
		scanf("%d %d %d %d %d %d %d",&n,&m,&k,&p,&q,&r,&mod);
		for(int i = 1;i <= k;i++){
			scanf("%d",&num[i]);
		}
		for(int i = k + 1;i <= n;i++){
			num[i] = ((ll)p % mod * num[i - 1] % mod + (ll)q % mod * i % mod + r % mod) % mod;
		}
		calculateA(n,m);
		calculateB(n,m);
		a = 0,b = 0;
		for(int i = 1;i <= n - m + 1;i++){
			a += (ll)ansA[i + m - 1] ^ i;
			b += (ll)ansB[i] ^ i;
		}
		printf("%lld %lld\n",a,b);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值