hdu 1679 The Unique MST 次小生成树 简单题

50 篇文章 0 订阅
17 篇文章 0 订阅
The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21737 Accepted: 7692

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
 
转载请申明原博客地址:http://blog.csdn.net/lionel_d
 
怎么判断生成树唯一不唯一呢?
只要判断他的次小生成树的总权值与最小生成树的总权值想不想等就可以了,如果相等的话,就说明,最小生成树不唯一,不相等的话,,,自然唯一啦!
次小生成树的求法,就是枚举边,然后再删除边,不断求次小的权值;
具体看博客:http://www.cnblogs.com/hxsyl/p/3290832.html
看代码:
#include <stdio.h>
#include <string.h>
#define MAX 110
#define INF 1000000000
int graph[MAX][MAX] , max[MAX][MAX];
bool used[MAX][MAX],visited[MAX] ;

int prim(int n)
{
	int lowCost[MAX],closest[MAX];
	memset(visited,false,sizeof(visited)) ;
	memset(used,false,sizeof(used)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		lowCost[i] = graph[1][i] ;
		closest[i] = 1 ;
	}
	visited[1] = true ;
	int sum=0;
	for(int i = 0 ; i < n-1  ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && min > lowCost[j])
			{
				min = lowCost[j];
				index = j ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		sum += lowCost[index] ;
		visited[index] = true ;
		used[index][closest[index]] = used[closest[index]][index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(visited[j] && index != j)
			{
				max[j][index] = max[index][j] = lowCost[index]>max[j][closest[index]]?lowCost[index]:max[j][closest[index]];
			}
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	return sum ;
}

int main()
{
	int t ;
	scanf("%d",&t) ;
	while(t--)
	{
		int n , m;
		scanf("%d%d",&n,&m) ;
		for(int i = 0 ; i <= n ; ++i)
		{
			graph[i][i] = INF ;
			for(int j = 0 ; j < i ; ++j)
			{
				graph[i][j] = graph[j][i] = INF ;
			}
		}
		for(int i = 0 ; i < m ; ++i)
		{
			int xi,yi,wi;
			scanf("%d%d%d",&xi,&yi,&wi);
			graph[xi][yi] = graph[yi][xi] = wi ;
		}
		int sum = prim(n) , t = INF ;
		for(int i = 1 ; i <= n ; ++i )
		{
			for(int j = 1 ; j < i ; ++j)
			{
				if(!used[i][j] && graph[i][j] != INF)
				{
					int r = sum-max[i][j]+graph[i][j];
					t = t>r?r:t ;
				}
			}
		}
		if(sum == t)
		{
			puts("Not Unique!") ;
		}
		else
		{
			printf("%d\n",sum) ;
		}
	}
	return 0 ;
}

与君共勉
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值