hdu 1141 Factstone Benchmark 数论水题,,阶乘用斯特林公式

154 篇文章 1 订阅
18 篇文章 0 订阅

Factstone Benchmark

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1760    Accepted Submission(s): 973


Problem Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.
 

Sample Input
  
  
1960 1981 0
 

Sample Output
  
  
3 8

不知道为什么,就是感觉数据很水。。我感觉我写的代码应该过不了的,结果过了
代码:
#include <stdio.h>
#include <math.h>
#define MAX 210
#define PI 3.14159265358979323846
#define E 2.7182818284590452354
int main()
{
	int ans[MAX] ;
	int j = 1 ;
	for(int i = 0; i < MAX ; ++i)
	{
		for( ; ; ++j)
		{
			if(0.5*log10(2*PI*j)+j*log10(j/E)>pow(2.0,i/10+2)*log10(2.0))
			{
				ans[i] = j-1 ;
				break ;
			}
		}
	}
	int year ;
	while(~scanf("%d",&year) && year)
	{
		printf("%d\n",ans[year-1960]);
	}
	return 0 ;
}

与君共勉

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值