hdu 1500 Chopsticks 动态规划 比较经典

154 篇文章 1 订阅
26 篇文章 0 订阅

Chopsticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1808    Accepted Submission(s): 836


Problem Description
In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)^2 is called the 'badness' of the set.
It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.
 

Input
The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).
 

Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
 

Sample Input
  
  
1 1 40 1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
 

Sample Output
  
  
23 Note For the sample input, a possible collection of the 9 sets is: 8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
 

先变成非递增序列,因为要保证有一个最大的C在每一组里面。

转移方程: dp[i][j] = Min(dp[i][j-1] , dp[i-1][j-2] + (set[j-1 - set[j] )* (set[j-1] -set[j]))

第i个人 第j个筷子的时候的最小值 

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 1000000000
using namespace std ;
int dp[1010][5100] ;

int min(int a , int b)
{
	return a>b?b:a ;
}

bool cmp(const int a , const int b)
{
	return a>b;
}

int main()
{
	int c[5100];
	int t;
	scanf("%d",&t) ;
	while(t--)
	{
		int n , k ;
		scanf("%d%d",&k,&n) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&c[i]) ;
		}
		sort(c+1,c+n+1,cmp);
		memset(dp,0,sizeof(dp)) ;
		for(int i = 1 ; i <= k+8 ; ++i)
		{
			int t = 3*i ;
			dp[i][t] = dp[i-1][t-2]+(c[t-1]-c[t])*(c[t-1]-c[t])  ; 	//保证前面i个人至少拿到筷子了 
			for(int j = t+1 ; j <= n ; ++j)
			{
				dp[i][j] = min(dp[i][j-1],dp[i-1][j-2]+(c[j-1]-c[j])*(c[j-1]-c[j]))  ;
			}
		}
		printf("%d\n",dp[k+8][n]) ;
	}
	return 0 ;
}

与君共勉

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值