poj 3186

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.
Input
Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)
Output
Line 1: The maximum revenue FJ can achieve by selling the treats
Sample Input
5
1
3
1
5
2
Sample Output
43
Hint
Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

题意:给定n个数
每次可以从头或者尾取出数据
于是按取出来得顺序,就可以排成一个数列,假设这个数列为
a1,a2,a3,a4…….an
现在我们假设按照取出来的顺序有一个权值
w=a1*1+a2*2+a3*3+….an*n
现在需要编程求出,如何控制取数的顺序,让w的值最大

分析:dp[i][j] 代表从头取了i个元素 j代表从尾取了多少元素。
注意边界,即i一个没取,j一个没取,别让i-1<0 或者j-1<0

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int dp[2010][2010];
int a[200000];
int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        int ans=0;
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j+i<=n;j++)
            {
                if(i>0&&j>0)
                dp[i][j]=max(dp[i-1][j]+a[i]*(i+j),dp[i][j-1]+a[n+1-j]*(i+j));
                else if(i>0)
                    dp[i][j]=dp[i-1][j]+a[i]*i;
                else if(j>0)
                    dp[i][j]=dp[i][j-1]+a[n-j+1]*j;
                ans=max(ans,dp[i][j]);
            }
        }
                   printf("%d\n",ans );
    }
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值