Error Curves(三分)uvalive 5009 求下凸 (最大值的最小值)

Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a
method called Linear Discriminant Analysis, which has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets. What’s more, each data is
divided into two parts: training data and test data. She gets the parameters of the model on training
data and test the model on test data.
To her surprise, she nds each dataset’s test error curve is just a parabolic curve. A parabolic curve
corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of
the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
It’s very easy to calculate the minimal error if there is only one test error curve. However, there
are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to
get the tuned parameters that make the best performance on all datasets. So she should take all error
curves into account, i.e., she has to deal with many quadric functions and make a new error de nition
to represent the total error. Now, she focuses on the following new function’s minimal which related to
multiple quadric functions.
The new function F(x) is de ned as follow:
F(x) = max(Si(x)); i = 1: : : n: The domain of x is [0;1000]. Si(x) is a quadric function:
Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem.
As a super programmer, can you help her?
Input
The input contains multiple test cases. The rst line is the number of cases T (T < 100). Each case
begins with a number n (n 10000). Following n lines, each line contains three integers a (0 a 100),
b (jbj 5000), c (jcj 5000), which mean the corresponding coefficients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000

转载至:http://www.th7.cn/Program/cp/201609/960392.shtml

大体题意:

给你n 个开口向上的抛物线,给你一个新的函数F(x),他的值是n 个抛物线的最大值,求Fx在[0,1000]的最小值?

思路:

三分法:

画一个抛物线可以知道,他是一个下凸函数,也有可能是一条直线,直线也可以看成是一个下凸函数!

画两个抛物线,无论这两个抛物线位置如何,还是一个下凸函数!

画多了就知道,无论怎么画抛物线,n个抛物线组成的fx 还是一个下凸函数!

因此存在唯一最小值!

我们可以用三分来求解!

单调用二分,凹凸用三分!

#include <bits/stdc++.h>
using namespace std;
int a[10010],b[10010],c[10010];
const double eps=1e-9;
int n;
double F(double x)
{
    double ans=a[0]*x*x+b[0]*x+c[0];
    for(int i=1;i<n;i++)
        ans=max(ans,a[i]*x*x+b[i]*x+c[i]);
    return ans;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
        {
            cin>>a[i]>>b[i]>>c[i];
        }
        double l=0.0,r=1000.0;
        while(r-l>eps)
        {
            double m1=l+(r-l)/3.0;
            double m2=r-(r-l)/3.0;
            if(F(m1)<F(m2))
                r=m2;
            else 
                l=m1;
        }
        printf("%.4f\n",F(l) );
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值