专题学习1 Hproblem-Error Curve

题目

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets.
What’s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?
Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000

题意

现在有n个二次方程,对于每一个x,F(x)等于在这点的n个二次方程中最大的值,求F(x)的最小值。

思路

刚刚拿到这题的时候头大的很,一大串的英文直接糊脸,只能慢慢看慢慢理解,但是其实好像很多情景题目一样,有一大堆是背景故事,其实是解题的无用信息来的。直接把注意力聚焦在F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). 也就是上面所说的题意。当然复合函数组成的图像肯定是很复杂的,但是在草稿纸上面对画画试一试就马上会发现,不管怎么画,它一定是一个单峰图像(主要是它限定了a>0啊,如果没有这个条件还真麻烦吧)。一旦确定它是一个单峰图像了,那么我们就可以直接给他上三分了,找最小值嘛。代码——安排。

#include<bits/stdc++.h>
struct node { double a; double b; double c; };
const int  N=1e4+10;
node fun[N];
double max(double a,double b) 
{ 
	if(a>b) 
		return a; 
	else 
	 	return b;
} 
double f(int i,double x)
{ 
	return fun[i].a*x*x+fun[i].b*x+fun[i].c; 
} 
double F(double x,int n)
{ 
	double maxi=f(1,x);
	for(int i=1;i<=n;i++) 
		maxi=max(maxi,f(i,x));
	return maxi;
} 
void sanfen(int n)
{ 
	int i;
	double l,r,mid1,mid2,y1,y2; 
	l=0,r=1000; 
	for(i=1;i<=100;i++) 
	{
		mid1=(2*l+r)/3;
		mid2=(l+2*r)/3; 
		y1=F(mid1,n);
		y2=F(mid2,n);
		if(y1>y2) 
		{ 
			l=mid1; 
		}
		else 
		{ 
			r=mid2; 
		} 
	} 
	double ans=F(l,n); 
	printf("%.4lf\n",ans);
} 

int main()
 { 
 	int n,t; scanf("%d",&t); 
  	while(t--) 
	{ 
	 	scanf("%d",&n); 
  		for(int i=1;i<=n;i++) 
 			scanf("%lf%lf%lf",&fun[i].a,&fun[i].b,&fun[i].c); 
		sanfen(n); 
	} 
	return 0; 
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值