HDU3714(Error Curves)三分求二次函数的极值

C - Error Curves
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.



It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
 

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
 

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.
 

Sample Input

     
     
2 1 2 0 0 2 2 0 0 2 -4 2
 

Sample Output

     
     
0.0000 0.5000
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;

const int N=10010;
const int M=100010;

int p[N],cir[N];
int n,m;

struct node
{
    int u,v,w;
} edge[M];

int cmp(node a,node b)
{
    return a.w>b.w;
}

int find(int x)
{
    if(p[x]==x)
        return x;
    p[x]=find(p[x]);
    return p[x];
}

bool union_set( int x,int y )
{
    int xx=find(x);
    int yy=find(y);
    if(xx==yy)
    {
        if(cir[xx]==-1)//形成一个环
        {
            cir[xx]=1;
            return 1;
        }
        return 0;
    }
    else
    {
        if(cir[xx]==cir[yy]&&cir[xx]==1)
            return 0;
        if(cir[xx]==1)//环作为祖先
            p[yy]=xx;
        else
            p[xx]=yy;
        return 1;
    }
}

int main()
{
    //freopen("C:\\Users\\Administrator\\Desktop\\kd.txt","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        if(!n&&!m)
            break;
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
        for(int i=0; i<n; i++)
        {
            p[i]=i;
            cir[i]=-1;
        }
        sort(edge,edge+m,cmp);
        int ans=0;
        for(int i=0; i<m; i++)
        {
            if(union_set(edge[i].u,edge[i].v))
                ans+=edge[i].w;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值