codeforces 628C Bear and String Distance 水

Limak is a little polar bear. He likes nice strings — strings of length n, consisting of lowercase English letters only.

The distance between two letters is defined as the difference between their positions in the alphabet. For example, , and .

Also, the distance between two nice strings is defined as the sum of distances of corresponding letters. For example, , and .

Limak gives you a nice string s and an integer k. He challenges you to find any nice string s’ that . Find any s’ satisfying the given conditions, or print “-1” if it’s impossible to do so.

As input/output can reach huge size it is recommended to use fast input/output methods: for example, prefer to use gets/scanf/printf instead of getline/cin/cout in C++, prefer to use BufferedReader/PrintWriter instead of Scanner/System.out in Java.

Input
The first line contains two integers n and k (1 ≤ n ≤ 105, 0 ≤ k ≤ 106).

The second line contains a string s of length n, consisting of lowercase English letters.

Output
If there is no string satisfying the given conditions then print “-1” (without the quotes).

Otherwise, print any nice string s’ that .

Example
Input
4 26
bear
Output
roar
Input
2 7
af
Output
db
Input
3 1000
hey
Output
-1

Description
定义两个小写字母之间的距离为这两个字母在字母表中的距离,如dis(a,z)=25,dis(a,c)=2,两个长度相同串的距离为这两个串对应位置字母距离之和。现给出一个长度为n的数字串s和一个距离k,问是否存在一个长度为n的串ss,使得dis(s,ss)=k,如果存在任意输出一解,如果不存在则输出-1
Input
第一行为两个整数n,k(1<=n<=10^5,1<=k<=10^6),第二行为一长度为n的数字串
Output
如果存在一个长度为n的数字串ss,使得dis(s,ss)=k则输出ss,如果不存在则输出-1
Sample Input
4 26
bear
Sample Output
roar

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    int k;
    cin>>n>>k;
    string s;
    cin>>s;
    int len=s.length();
    int ans=0;
    for(int i=0;i<len;i++)
    {
        ans+=max((int)(s[i]-'a'),(int)('z'-s[i]));
    }
    if(ans<k)
    {
        printf("-1\n");
        return 0;
    }
    else
    {
        for(int i=0;i<len;i++)
        {
            int res1='z'-s[i];
            int res2=abs('a'-s[i]);
            int flag=0;
            int res=res1;
            if(res1<res2)
            {
                res=res2;
                flag=1;
            }
            if(res>k&&k!=0)
            {
                if(!flag)
                printf("%c",s[i]+k);
                else printf("%c",s[i]-k);
                k=0;
            }
            else if(k==0)
            {
                printf("%c",s[i]);
            }
            else
            {
                if(!flag)
                printf("z");
                else printf("a");
                k-=res;
            }
        }
        cout<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值