For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
//一开始完全没有看懂题目的意思,就是说从字符串的第二个开始,看前面是循环串吗,是的话就输出此时的位置,和循环串的周期,周期必须大于1
利用 循环节长度是 长度减去 f[尾部] 所以 一边跑一遍输出就好
#include <bits/stdc++.h>
using namespace std;
const int N = 1001000;
char a[N];
int f[N];
void getfill(char *s,int len)
{
memset(f,0,sizeof(f));
f[0]=-1;
for(int i=1;i<=len;i++)
{
int j=f[i];
while(j&&s[i]!=s[j])
j=f[j];
f[i+1]=(s[i]==s[j])?j+1:0;
}
}
int main()
{
int n,cas=1;
while(scanf("%d",&n)&&n)
{
scanf(" %s",a+1);
int len=strlen(a+1);
getfill(a+1,len);
// for(int i=1;i<=len;i++)
// printf("%d ",f[i] );
// printf("\n");
printf("Test case #%d\n",cas++ );
for(int i=2;i<=len;i++)
{
int len=i-f[i];
if(f[i]&&len!=0&&i%len==0)
{
printf("%d %d\n",i,i/len );
}
}
printf("\n");
}
}