hihocoder 1236 (分块+bitset乱搞)

Kyle is a student of Programming Monkey Elementary School. Just as others, he is deeply concerned with his grades.

Last month, the school held an examination including five subjects, without any doubt, Kyle got a perfect score in every single subject.

There are n students took part in this examination(not including Kyle), and everyone got an integer between 1 to m as the score of one subject.

Now, looking at the grade table of these n students, Kyle wants to know how many students still did no better than him even if his scores are something else – Here, “no better” means there is no subject in which the student got strictly greater score than Kyle.

Input
There are multiple test cases.

The first line of the input contains an integer T (T <= 3) which means the number of test cases.

The first line of each test case contains two integers, n, m(n, m≤ 50,000), which are the number of students and the perfect score of each subject.

In the next n lines, each line consists of five integers, indicating a student’s scores.

Then one line follows. This line contains an integer q(q≤ 50,000) indicating the number of queries.

In the next q lines, each line contains five integers as well, representing a query. Each query indicates a set of scores, and for each query, you should figure out that if Kyle’s grade is this set of scores, how many students still did no better than him. But for the sake of security, only the first query is in its original form, and other queries are encrypted. To decrypt a query, you must let each integer in the query do xor operation with the answer of last query. It’s guaranteed that all the decrypted queries contain integers between 1 and 50000.

Output
For each test case, you should output q lines as the answer for all queries.

Sample Input
2
2 3
1 1 1 1 1
2 2 2 2 2
2
1 1 1 1 1
3 3 3 3 3
3 5
1 1 1 1 1
1 1 1 1 1
1 2 3 4 5
2
1 1 1 1 1
1 1 1 1 1
Sample Output
1
2

每个同学 5门科目成绩,给你q个询问,问不严格小于该成绩的同学个数
很容易想到的是用bitset 把小于该成绩的同学全部加进去,最后一个与就行了,可是怎么加进去呢,每次暴力肯定不行 5e4*5e4*5的 时间复杂度直接爆炸,考虑分块,因为已经排好序了,所以找到最后一个小于等于这个成绩的同学在哪一块,那么全部的块全是满足条件的,剩下的暴力加进去就好,可以想到这样的时间复杂度是 最坏情况,5e4*sqrt(5e4)*5的,对于4s,完全足够了

#include <bits/stdc++.h>
using namespace std;


struct node
{
    int v,cur;
    bool operator <(const node &rhs) const
    {
        if(v==rhs.v) return cur<rhs.cur;
        return v<rhs.v;
    }
}a[6][50010];

bitset<50010> b[6][500];
bitset<50010> ans,temp;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=5;j++)
            {
                scanf("%d",&a[j][i].v);
                a[j][i].cur=i;
            }
        }
        for(int i=1;i<=5;i++)
            sort(a[i]+1,a[i]+n+1);
        int sqrn=sqrt(n);
        for(int i=1;i<=5;i++)
        {
            for(int j=1;(j-1)*sqrn<n;j++)
            {
                int st=(j-1)*sqrn;
                b[i][j].reset();
                b[i][j]=b[i][j-1];
                for(int k=1;st+k<=n&&k<=sqrn;k++)
                {
                    b[i][j].set(a[i][st+k].cur);
                }
            }
        }
        int q;
        int pre=0;
        scanf("%d",&q);
        while(q--){
            int d;
            ans.reset();
            for(int i=1;i<=5;i++)
            {
                scanf("%d",&d);
                d^=pre;
                int pos=lower_bound(a[i]+1,a[i]+n+1,(node){d,n+1})-a[i]-1;
                int tmp=pos/sqrn;
                temp=b[i][tmp];
                for(int j=tmp*sqrn+1;a[i][j].v<=d&&j<=n;j++)
                    temp.set(a[i][j].cur);
                if(i==1)
                    ans=temp;
                else ans&=temp;
            }
            int cou=ans.count();
            pre=cou;
            printf("%d\n",cou );
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值