《动态规划》— POJ 3624 Charm Bracelet(01背包)

Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38399 Accepted: 16661

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver

 

题目大意:魔力手镯,      贝茜只能支持一个迷人的手镯  重量不超过M(1≤≤12880),每一个魔力手镯的Wi,,Di.典型的01背包问题。背包容量为M.注意数组大小。

状态转移方程:dp[j] = max(dp[j] ,dp[j-vol[i]] + val[i])

 

#include <iostream>  
#include <cstdio>  
using namespace std;  
#define max(a,b)    ((a)>(b)?(a):(b))  
const int maxn = 3405;  
int main()  
{  
    int n, v;  
    int dp[4*maxn], val[maxn], vol[maxn];  
    while (scanf("%d %d", &n, &v) != EOF)  
    {  
        int i, j;  
        for (i=0; i<n; i++) scanf("%d %d", &vol[i], &val[i]);  
        memset(dp, 0, sizeof(dp));  
  
        for (i=0; i<n; i++)  
            for (j=v; j>=vol[i]; j--)  
                if (dp[j] < dp[j-vol[i]] + val[i])   //状态转移方程
                    dp[j] = dp[j-vol[i]] + val[i];  
  
        printf("%d\n", dp[v]);  
    }  
    return 0;  
} 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值