周练D - Jam's math problem

D - Jam's math problem
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Jam has a math problem. He just learned factorization. 
He is trying to factorize   into the form of 
He could only solve the problem in which p,q,m,k are positive numbers. 
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input

The first line is a number  , means there are   cases 

Each case has one line,the line has   numbers 
 

Output

You should output the "YES" or "NO".
 

Sample Input

     
     
2 1 6 5 1 6 4
 

Sample Output

     
     
YES NO

Hint

 The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$ 



这个题我刚开始做的是用一个二维数组,把mpqk的所有情况全部列举出来,但是不知道为啥,一直wa,后来看别人代码都很简单,说是根号下德尔塔一定是整数,找了几个大神,也没解释出所以然,后来又看到另一种方法,跟我第一次的差不多,试着敲了一遍,就过了,真神奇!


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 p[10000010][2],q[10000010][2];
int main()
{
	__int64 i,j,m,a,b,c,z,x;
	scanf("%I64d",&m);
	while(m--)
	{
		scanf("%I64d%I64d%I64d",&a,&b,&c);
		int flag=0;
		for(i=1;i*i<=a;i++)
		{
			if(a%i==0)
			{
				z=a/i;
				for(j=1;j*j<=c;j++)
				{
					if(c%j==0)
					{
						x=c/j;
						if(i*j+z*x==b||i*x+j*z==b)
						{
							flag=1;
							break;
						}
					}
				}

			}
				if(flag)
				break;
		}
		if(flag)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值