Jam's math problem

Jam's math problem
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit

Status

Practice

HDU 5615
Description
Jam has a math problem. He just learned factorization.
He is trying to factorize ax^2+bx+c into the form of pqx^2+(qk+mp)x+km=(px+k)(qx+m).
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
Input
The first line is a number T, means there are T(1 \leq T \leq 100 ) cases

Each case has one line,the line has 3 numbers a,b,c (1 \leq a,b,c \leq 100000000)
Output
You should output the "YES" or "NO".
Sample Input
2
1 6 5
1 6 4
Sample Output
YES
NO




Hint

就是看看能不能分解因式:

#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	long long a,b,c,i,j;
	scanf("%d",&t);
	while(t--)
	{
		int f=0;
		scanf("%lld %lld %lld",&a,&b,&c);
		for(i=1;i*i<=a;i++)
		{
			if(a%i!=0)
			continue;
			for(j=1;j*j<=c;j++)
			{
				if(c%j!=0)
				continue;
				if((i*(c/j)+j*(a/i))==b||(i*j+(c/j)*(a/i))==b)
				{
					f=1;
				}
			}
		}
		if(f==1)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值