A problem is easy
时间限制:
1000 ms | 内存限制:
65535 KB
难度:
3
-
描述
-
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :
Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?
Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?-
输入
- The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11). 输出
- For each case, output the number of ways in one line 样例输入
-
2 1 3
样例输出
-
0 1
上传者
这是一个数学题目,找出规律就可以了
我们看题目要求,N= i * j + i + j (0 < i <= j)
我们让等式两边同时加以1 i*(j+1)+j+1=N+1
所以 (i+1)*(j+1)=N+1
所以只要是N+1可以整除j即可
j的取值范围就是1-sqrt(N)-1
所以计算个数就行了
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
int a,b,c,d,i,j,m,n,sum;
scanf("%d",&m);
while(m--)
{
sum=0;
scanf("%d",&n);
for(i=1;i<=sqrt(n)-1;i++)
{
if((n+1)%(i+1)==0)
sum++;
}
printf("%d\n",sum);
}
return 0;
}