南阳题目287-Radar

Radar

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

 

输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
来源


这个题目就是要反过来想,以每个岛屿为圆心画圆,与坐标轴的两个交点存起来,然后按后面的坐标升序排列。就转换成了一个区间选点的问题。



#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct node {
	double b,e;
}s[100100];
bool cmp(node x,node y)
{
	return x.e<y.e;
}
int main()
{
	int m,n,a,b,i,j,cot=1,tt;
	double t;
	while(scanf("%d%d",&m,&n),m+n)
	{
		tt=0;
		int flag=0;
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			if(abs(b)>n)
			flag=1;
			s[i].b=a-sqrt(n*n-b*b);
			s[i].e=a+sqrt(n*n-b*b);
		}
		sort(s,s+m,cmp);
		t=s[0].e;
		for(i=1;i<m;i++)
		{
			if(s[i].b>t)
			{
				tt++;
				t=s[i].e;
			}
		}
		if(flag)
		printf("Case %d: -1\n",cot++);
		else
		printf("Case %d: %d\n",cot++,tt+1);
	}
	return 0;
 } 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值