南阳题目220-推桌子

推桌子

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
输出
The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50
样例输出
10
20
30
上传者



这个题目,前面的处理就是让其变成题目要求的情况,然后就是求区间覆盖问题了,求其最大的覆盖长度。




#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int p[10010];
struct node
{
	int x,y;
 } s[10010];
 int main()
 {
 	int a,b,m,n,i,M,j,k;
 	scanf("%d",&M);
 	while(M--)
 	{
 		memset(p,0,sizeof(p));
 		scanf("%d",&m);
 		for(i=0;i<m;i++)
 		{
 			scanf("%d%d",&a,&b);
 			a=(a+1)/2;
 			b=(b+1)/2;
 			if(a>b)
 			swap(a,b);
 			s[i].x=a;
 			s[i].y=b;
		 }
		 int ma=0;
		 for(i=0;i<m;i++)
		 {
		 	for(j=s[i].x;j<=s[i].y;j++)
		 	{
		 		p[j]+=10;
		 		if(ma<p[j])
		 		ma=p[j];
			 }
		 }
		 printf("%d\n",ma);
	 }
	 return 0;
 }



然后我自己想的另一种方法是每次求不相交的区间,取玩为止,然后求出最少次数,但是,我也不太清楚为什么要这样排序


1,按开始排序,从前向后找

2,按结束排序,从后向前找




#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int x,y,f;
}s[100100];
bool cmp(node x,node y)
{
	return x.x<y.x;//按开始排序
}
int main()
{
	int a,b,c,m,n,i,j;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			a=(a+1)/2;
			b=(b+1)/2;
			if(a>b)
			swap(a,b);
			s[i].x=a;
			s[i].y=b;
			s[i].f=0;
		}
			
		sort(s,s+n,cmp);
		int t,j=0,cot=0;
		for(i=0;i<n;i++)
		{
			if(!s[i].f)
			{
				t=s[i].y;
				s[i].f=1;
				cot++;
				for(j=i+1;j<n;j++)
				{
					if(s[j].f==0&&s[j].x>t)
					{
						t=s[j].y;
						s[j].f=1;
					}
				}
			}
		}
	printf("%d\n",cot*10);
	}
	return 0;
}



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int x,y,f;
}s[100100];
bool cmp(node x,node y)
{
	return x.y<y.y;//按结束排序
}
int main()
{
	int a,b,c,m,n,i,j;
	scanf("%d",&m);
	while(m--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			a=(a+1)/2;
			b=(b+1)/2;
			if(a>b)
			swap(a,b);
			s[i].x=a;
			s[i].y=b;
			s[i].f=0;
		}
			
		sort(s,s+n,cmp);
		int t,j=0,cot=0;
		for(i=n-1;i>=0;i--)
		{
			if(!s[i].f)
			{
				t=s[i].x;
				s[i].f=1;
				cot++;
				for(j=i-1;j>=0;j--)
				{
					if(s[j].f==0&&s[j].y<t)
					{
						t=s[j].x;
						s[j].f=1;
					}
				}
			}
		}
	printf("%d\n",cot*10);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值