YT15-HDU-坐电梯要不要这么麻烦

Problem Description

 

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

 

Input

 

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

 

Output

 

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

 

Sample Input

 

5 1 5
3 3 1 2 5
0

 

Sample Output

 

3

代码如下:

#include <iostream>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f3f         //无穷大
int pb[201],floor[201][2];     //pb即Press the button按按钮 表示从起点到第i层的按按钮的最少次数
//floor[i][0]表示第i层向上能到的楼层,floor[i][1]则表示向下能到的楼层。
int main()
{
    int n,a,b,t,i,num,j;
    while(cin>>n&&n!=0)
    {
        cin>>a>>b;
        memset(floor,-1,sizeof(floor));             //先将所有楼层初始化为-1
        for(i=1; i<=n; i++)
        {
            cin>>t;
            if(i+t<=n)                              //不能高于最高楼层
                floor[i][0]=i+t;
            if(i-t>=1)                              //不能低于最低楼层
                floor[i][1]=i-t;
        }
        memset(pb,0x3f,sizeof(pb));
        pb[a]=0;                                    //起点位置按按钮次数为0
        do
        {
            num=0;                                  //记录更新数据的次数
            for(i=1; i<=n; i++)                     //枚举1~n层
                for( j=0; j<2; j++)                 //枚举向上还是向下
                    if(pb[floor[i][j]]>pb[i]+1&&floor[i][j]!=-1) //判断i到floor[i][j]是否更近且判断下一个位置是否可导
                    {
                        pb[floor[i][j]]=pb[i]+1;     //更新
                        num++; 
                    }
            if(num==0)                              //无法继续更新
                break;
        }while (1);
        if(pb[b]==INF)
            pb[b]=-1;
        cout<<pb[b]<<endl;
    }
    return 0;
}


运行结果:

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值