sdnu oj 1099 前缀判断

1099.前缀判断

Time Limit: 1000 MS    Memory Limit: 32768 KB
Total Submission(s): 436    Accepted Submission(s): 63

Description

给定 n 个字符串,求有多少字符串是其他字符串的前缀。

Input

第一行为一个整数n(1 <= n <= 1000),之后n行,每行一个字符串,字符串只由26个小写字母组成,最大长度为100。

Output

一个整数,有多少字符串是其他字符串的前缀。

Sample Input

5
abcde
ab
bcde
b
cde

Sample Output

2

Source

Unknown

© 2012-2015 SDNU ACM-ICPC TEAM, v1.2 Beta

这道题师哥们规定了要用set来做。所以先自学set后再来做这个题,需要注意的都在备注上。

Source Code View

Run ID: 57517  /  Problem ID: 1099  /  Author: 2017Liushilei  /  Language: C++
Submit Time: 2017-11-11 18:22:57  /  Judge Status: Accepted  /  Judge Time: 2017-11-11 18:23:00
1
#include<cstdio>
2
#include<iostream>
3
#include <cmath>
4
#include<string>
5
#include<set>
6
#include<iterator>
7
#include<cstring>
8
using namespace std;
9
#define N 10001
10
using namespace std;
11
int main()
12
{
13
    int n,t=0,b,a;
14
    string c[1010];
15
    set <string> s;    //存储所有前缀
16
    set <string> p;    //判断是否出现过重复字符串
17
    set <string> chu;  //存储重复出现过的字符串
18
    cin >> n;
19
    for(int i=0; i<n; i++){
20
        cin >> c[i];
21
        if(p.count(c[i]))     //判断是否出现过重复字符串
22
        {
23
            chu.insert(c[i]); //将重复出现的字符串放入其中
24
        }
25
        p.insert(c[i]);
26
        //cout << c[i].length() <<endl;
27
        for(int j=1; j<c[i].length(); j++){
28
            string str=c[i].substr(0,j);   //找出所有的前缀放入s中
29
            s.insert(str);
30
        }
31
    }
32
    for(int i=0; i<n; i++){
33
        if(chu.count(c[i]))   //如果重复出现过,他一定是其他字符串的前缀
34
            t++;
35
        else if(s.count(c[i]))   //如果他是其他字符串的前缀
36
            t++;
37
        else continue;
38
    }
39
    cout << t << endl;
40
    return 0;
41
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值