poj1276Cash Machine ——多重背包二进制优化

16 篇文章 0 订阅

原题链接:poj1276 cash machine

Language:Default
Cash Machine
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 36835
Accepted: 13373
Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output

735
630
0
0
Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
Source

Southeastern Europe 2002
题意:银行有一台取钱的机器 机器里有不同面值不同数量的钞票 给你一个想取的钱的价值 问小于等于这个价值的最大值是多少

思路:标准的多重背包 可以简单的把n张钞票设为n件物品转化为01背包 但应该会超时
用到了二进制的优化 (背包问题九讲)
我们考虑把第i种物品换成若干件物品,使得原问题中第i种物品可取的每种策略——取0…Mi件——均能等价于取若干件代换以后的物品。另外,取超过Mi件的策略必不能出现。
方法是:将第i种物品分成若干件01背包中的物品,其中每件物品有一个系数。这件物品的费用和价值均是原来的费用和价值乘以这个系数。令这些系数分别为1; 2; 22 …2k−1; Mi − 2k + 1,且k是满足Mi − 2k + 1 > 0的最大整数。例如,如果Mi为13,则相应的k = 3,这种最多取13件的物品应被分成系数分别
为1; 2; 4; 6的四件物品。
分成的这几件物品的系数和为Mi,表明不可能取多于Mi件的第i种物品。
另外这种方法也能保证对于0…Mi间的每一个整数,均可以用若干个系数的和表示。这里算法正确性的证明可以分0… 2k−1和2k… Mi两段来分别讨论得出
这样就将第i种物品分成了O(logMi)种物品,将原问题转化为了复杂度为O(V ΣlogMi)的01背包问题,是很大的改进。
下面给出O(logM)时间处理一件多重背包中物品的过程:

def MultiplePack(F ,C,W ,M)
 if C · M ≥ V
  CompletePack(F ,C,W )
  return
 k = 1
 while k < M
  ZeroOnePack(kC,kW )
  M = M − k
  k = 2k
 ZeroOnePack(C · M,W · M)
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 100010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int n;
int num[20],cash[20];
int dp[100100];
int main(int argc, char const *argv[])
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(num,0,sizeof(num));
        memset(cash,0,sizeof(cash));
        memset(dp,0,sizeof(dp));
        int t,i,j;
        scanf("%d",&t);
        for(i=1;i<=t;i++)
            scanf("%d%d",&num[i],&cash[i]);
        for(i=1;i<=t;i++)
        {
            if(num[i]*cash[i]>n)
            {
                for(j=cash[i];j<=n;j++)
                    dp[j]=max(dp[j],dp[j-cash[i]]+cash[i]);
            }
            else
            {
                int k=1;
                while(k<num[i])
                {
                    for(j=n;j>=k*cash[i];j--)
                        dp[j]=max(dp[j],dp[j-k*cash[i]]+k*cash[i]);
                    num[i]-=k;
                    k*=2;
                }
                for(j=n;j>=num[i]*cash[i];j--)
                    dp[j]=max(dp[j],dp[j-cash[i]*num[i]]+num[i]*cash[i]);
            }
        }
        printf("%d\n",dp[n] );
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值