Arctic Network
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 23026 | Accepted: 7082 |
Description
The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.
Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.
Input
The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).
Output
For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.
Sample Input
1 2 4 0 100 0 300 0 600 150 750
Sample Output
212.13
题意:给定所有哨所的坐标 哨所直接有两种联系的方式 一种是卫星 可以不受距离限制 一种是直接与距离小于d的哨所通信 问d的最小值
思路:最小生成树 用给定的卫星去取代最长的边即可 也就是只在整个图中添加p-s条边
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#define max_ 550
using namespace std;
struct edge
{
int u,v;
double w;
bool operator < (const edge &a)const
{
return a.w<w;
}
}e;
int s,p,num[max_][2],pre[max_];
priority_queue<edge>q;
double dis(int i,int j)
{
int tx=(int)fabs(num[i][0]-num[j][0]);
int ty=(int)fabs(num[i][1]-num[j][1]);
return (sqrt((tx*tx)+(ty*ty)));
}
int find(int x)
{
return pre[x]==x?x:pre[x]=find(pre[x]);
}
double kruskal()
{
int cnt=0;
double minn=0x3f3f3f3f;
while(q.size())
{
e=q.top();
q.pop();
int tx=find(e.u);
int ty=find(e.v);
if(tx!=ty)
{
pre[tx]=ty;
cnt++;
minn=e.w;
}
if(cnt==p-s)
return minn;
}
return 0;
}
int main(int argc, char const *argv[])
{
int t,i,j;
scanf("%d",&t);
while(t--)
{
while(q.size())
q.pop();
scanf("%d%d",&s,&p);
for(i=1;i<=p;i++)
{
scanf("%d%d",&num [i][0],&num[i][1]);
for(j=1;j<i;j++)
{
e.u=i;
e.v=j;
e.w=dis(i,j);
q.push(e);
}
pre[i]=i;
}
printf("%.2f\n",kruskal());
}
return 0;
}