HDU - 3974 Assign the task —— 并查集

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3624    Accepted Submission(s): 1498


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
  
  
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
  
  
Case #1: -1 1 2


题意 :公司中有n个员工  除了boss  每个员工都有自己的上司  自己下属的下属也是自己的下属  当给一个员工分配任务时  这个员工会把任务也分配到自己的所有下属   每个员工都只做最后一个被分配的任务  对于每个C x  输出员工x正在做的任务  没有就输出-1


思路:不是标准答案 只是数据小 用并查集水过了!!!


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 50010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int task[max_],pre[max_],time[max_];
int n,m,ti=1;
void query(int x)
{
	int t=-1,nt=0;
	while(pre[x]!=x)
	{
		if(task[x]!=-1&&time[x]>nt)
		{
			t=task[x];
			nt=time[x];
		}
		x=pre[x];
	}
	if(task[x]!=-1&&time[x]>nt)
	{
		t=task[x];
		nt=time[x];
	}	
	printf("%d\n",t);
}
void update(int x,int t)
{
	task[x]=t;
	time[x]=ti++;
}
int main(int argc, char const *argv[])
{
	int t,r,i;
	scanf("%d",&t);
	for(r=1;r<=t;r++)
	{
		memset(task,0,sizeof(task));
		memset(pre,0,sizeof(pre));
		memset(time,0,sizeof(time));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			pre[i]=i;
			task[i]=-1;
		}
		for(i=1;i<n;i++)
		{
			int u,v;
			scanf("%d%d",&u,&v);
			pre[u]=v;
		}
		scanf("%d",&m);
		printf("Case #%d:\n",r);
		while(m--)
		{
			char c;
			int x,y;
			scanf(" %c",&c);
			if(c=='C')
			{
				scanf("%d",&x);
				query(x);
			}
			else if(c=='T')
			{
				scanf("%d%d",&x,&y);
				update(x,y);
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值