POJ - 3070 Fibonacci —— 矩阵快速幂

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16668 Accepted: 11670

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

题意:给定一个很大的数n,求斐波那契数列中的第n个数模10000的结果。


思路:

在斐波那契数列中,有 f(n) = 1*f(n-1) + f(n-2)    f(n-1) = 1*f(n-1) + f(n-2) ,所以


所以只要求出矩阵的n-1次方是多少就可以了。

和数的快速幂相似,把数的乘法换成矩阵的乘法即可。

最后要记得特判0...

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 200010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

struct mat
{
    ll num[2][2];
};
struct mat a;
mat mult(mat a,mat b)
{
    mat ans;
    memset(ans.num,0,sizeof(ans.num));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                ans.num[i][j]+=(a.num[i][k]*b.num[k][j]);
                ans.num[i][j]%=10000;
            }
        }
    }
    return ans;
}
int fpow(ll b)
{
    mat ans;
    ans.num[0][0]=1;
    ans.num[1][1]=1;
    ans.num[0][1]=0;
    ans.num[1][0]=0;
    mat tmp;
    tmp.num[0][0]=1;
    tmp.num[1][1]=0;
    tmp.num[0][1]=1;
    tmp.num[1][0]=1;
    while(b!=0)
    {
        if(b&1)
            ans=mult(ans,tmp);
        b/=2;
        tmp=mult(tmp,tmp);
    }
    return ans.num[0][0];
}
int main(int argc, char const *argv[]) {
    ll n;
    while(cin>>n&&n!=-1)
    {
        if(n==0)
        printf("0\n");
        else
        printf("%d\n",fpow(n-1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值