HDU - 1047 Integer Inquiry

5 篇文章 0 订阅

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22232    Accepted Submission(s): 6027


Problem Description
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
 

Output
Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Sample Input
  
  
1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
 

Sample Output
  
  
370370367037037036703703703670


vector的模拟

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 100010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

vector<int>v[4];
void add(string a)
{
	v[0].clear();
	v[2].clear();
	int i=a.size()-1;
	while(a[i]=='0'&&i>=1)
		i--;
	for(;i>=0;i--)
	{
		v[0].push_back((a[i]-'0'));
	}
	if(v[0].size()>v[1].size())
		swap(v[0],v[1]);
	i=0;
	int cf=0;
	int l=v[0].size();
	for(;i<l;i++)
	{
		int d=v[0][i]+v[1][i]+cf;
		v[2].push_back(d%10);
		cf=d/10;
	}
	l=v[1].size();
	for(;i<l;i++)
	{
		int d=v[1][i]+cf;
		v[2].push_back(d%10);
		cf=d/10;
	}
	while(cf!=0)
	{
		v[2].push_back(cf%10);
		cf/=10;
	}
	v[1]=v[2];
}
int main(int argc, char const *argv[])
{
	int t;
	cin>>t;
	while(t--)
	{
		string a;
		for(int i=0;i<4;i++)
			v[i].clear();
		int f=0;
		while(cin>>a&&a!="0")
		{
			f=1;
			add(a);
		}
		if(f==0)
			printf("0");
		for(int i=v[2].size()-1;i>=0;i--)
		{
			printf("%d",v[2][i]);
		}
		printf("\n");
		if(t!=0)
			printf("\n");
	}
	// system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值