POJ - 2142 The Balance —— 扩展欧几里得

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8159 Accepted: 3560

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

题意:给定两种秤砣,问最少用几个可以称出物品的重量,输出每种用的个数

思路:

用扩展欧几里得跑一下两个秤砣的重量,然后相加减找最小的个数和

要注意负数表示的是在称的另一端放秤砣

巨巨说不用这么麻烦...最小个数和一定出现在x取最小正数或者y取最小正数的时候

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#define max_ 1000100
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-8
#define mod 9901
using namespace std;
int a,b,d;
int x,y;
int exgcd(int a,int b,int &x,int &y)
{
	if(b==0)
	{
		x=1;
		y=0;
		return a;
	}
	int k=exgcd(b,a%b,y,x);
	y-=a/b*x;
	return k;
}
int main(int argc, char const *argv[]) {
	while(scanf("%d%d%d",&a,&b,&d)!=EOF)
	{
		if(a==0&&b==0&&d==0)
		break;
		int gcd=exgcd(a,b,x,y);
		x=x*d/gcd;
		y=y*d/gcd;
		int minn=inf;
		int minnn=inf;
		int dx=x;
		int dy=y;
		int ansx,ansy;
		while(abs(x)<=minn)
		{
			int tx=abs(x);
			int ty=abs(y);
			if(minn==tx+ty)
			{
				if(minnn>a*tx+b*ty)
				{
					minnn=a*tx+b*ty;
					ansx=tx;
					ansy=ty;
				}
			}
			else if(minn>tx+ty)
			{
				minn=tx+ty;
				minnn=a*tx+b*ty;
				ansx=tx;
				ansy=ty;
			}
			x+=b/gcd;
			y-=a/gcd;
		}
		x=dx;
		y=dy;
		while(abs(y)<=minn)
		{
			int tx=abs(x);
			int ty=abs(y);
			if(minn==tx+ty)
			{
				if(minnn>a*tx+b*ty)
				{
					minnn=a*tx+b*ty;
					ansx=tx;
					ansy=ty;
				}
			}
			if(minn>tx+ty)
			{
				minn=tx+ty;
				minnn=a*tx+b*ty;
				ansx=tx;
				ansy=ty;
			}
			x-=b/gcd;
			y+=a/gcd;
		}
		printf("%d %d\n",ansx,ansy);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值