HDU - 2962 Trucking —— 最短路加条件

Trucking

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11544    Accepted Submission(s): 1127


 

Problem Description

A certain local trucking company would like to transport some goods on a cargo truck from one place to another. It is desirable to transport as much goods as possible each trip. Unfortunately, one cannot always use the roads in the shortest route: some roads may have obstacles (e.g. bridge overpass, tunnels) which limit heights of the goods transported. Therefore, the company would like to transport as much as possible each trip, and then choose the shortest route that can be used to transport that amount.

For the given cargo truck, maximizing the height of the goods transported is equivalent to maximizing the amount of goods transported. For safety reasons, there is a certain height limit for the cargo truck which cannot be exceeded.

 

 

Input

The input consists of a number of cases. Each case starts with two integers, separated by a space, on a line. These two integers are the number of cities (C) and the number of roads (R). There are at most 1000 cities, numbered from 1. This is followed by R lines each containing the city numbers of the cities connected by that road, the maximum height allowed on that road, and the length of that road. The maximum height for each road is a positive integer, except that a height of -1 indicates that there is no height limit on that road. The length of each road is a positive integer at most 1000. Every road can be travelled in both directions, and there is at most one road connecting each distinct pair of cities. Finally, the last line of each case consists of the start and end city numbers, as well as the height limit (a positive integer) of the cargo truck. The input terminates when C = R = 0.

 

 

Output

For each case, print the case number followed by the maximum height of the cargo truck allowed and the length of the shortest route. Use the format as shown in the sample output. If it is not possible to reach the end city from the start city, print "cannot reach destination" after the case number. Print a blank line between the output of the cases.

 

 

Sample Input

 

5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 10 5 6 1 2 7 5 1 3 4 2 2 4 -1 10 2 5 2 4 3 4 10 1 4 5 8 5 1 5 4 3 1 1 2 -1 100 1 3 10 0 0

 

 

Sample Output

 

Case 1: maximum height = 7 length of shortest route = 20 Case 2: maximum height = 4 length of shortest route = 8 Case 3: cannot reach destination

题意:

每条路有长度和限高,问从起点到终点可以走的最大高度和在这个高度下的最短路径

思路:

这种在最短路的的条件上在加其他线性条件的基本都可以二分第二个条件来做,这个题也是。

二分最大高度(虽然没给最大高度的范围),在每一个高度下找起点到终点的最短路

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
	int to;
	int w;
	int h;
	bool operator < (const node &a)const
	{
		return a.w<w;
	}
}zz;
vector< vector<struct node> >v;
int n,m;
int st,ed,maxh;
bool vis[1010];
int dis[1010];
int casnum=1;
bool dij(int hg)
{
	memset(vis,false,sizeof vis);
	for(int i=1;i<=n;i++)
		dis[i]=inf;
	dis[st]=0;
	priority_queue<struct node>q;
	zz.to=st;
	zz.w=0;
	q.push(zz);
	while(!q.empty())
	{
		node tp=q.top();
		q.pop();
		int u=tp.to;
		if(vis[u])
		continue;
		vis[u]=true;
		if(u==ed)
		return true;
		for(int i=v[u].size()-1;i>=0;i--)
		{
			int d=v[u][i].to;
			if(vis[d]==false&&v[u][i].h>=hg)
			{
				if(dis[u]+v[u][i].w<dis[d])
				{
					dis[d]=dis[u]+v[u][i].w;
					zz.to=d;
					zz.w=dis[d];
					q.push(zz);
				}
			}
		}
	}
	return false;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
		break;
		if(casnum!=1)
		printf("\n");
		v.clear();
		v.resize(n+1);
		for(int i=1;i<=m;i++)
		{
			int x,y;
			scanf("%d%d%d%d",&x,&y,&zz.h,&zz.w);
			if(zz.h==-1)
			zz.h=inf;
			zz.to=y;
			v[x].push_back(zz);
			zz.to=x;
			v[y].push_back(zz);
		}
		scanf("%d%d%d",&st,&ed,&maxh);
		int l=1,r=maxh;
		int path;
		int high;
		while(l<=r)
		{
			int mid=(l+r)>>1;
			if(dij(mid))
			{
				high=mid;
				path=dis[ed];
				l=mid+1;
			}
			else
			{
				r=mid-1;
			}
		}
		printf("Case %d:\n",casnum++);
		if(path>=inf)
		{
			printf("cannot reach destination\n");
			continue;
		}
		else
		{
			printf("maximum height = %d\n",high);
			printf("length of shortest route = %d\n",path);
		}
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的公寓报修管理系统,源码+数据库+毕业论文+视频演示 现代经济快节奏发展以及不断完善升级的信息化技术,让传统数据信息的管理升级为软件存储,归纳,集中处理数据信息的管理方式。本公寓报修管理系统就是在这样的大环境下诞生,其可以帮助管理者在短时间内处理完毕庞大的数据信息,使用这种软件工具可以帮助管理人员提高事务处理效率,达到事半功倍的效果。此公寓报修管理系统利用当下成熟完善的Spring Boot框架,使用跨平台的可开发大型商业网站的Java语言,以及最受欢迎的RDBMS应用软件之一的MySQL数据库进行程序开发。公寓报修管理系统有管理员,住户,维修人员。管理员可以管理住户信息和维修人员信息,可以审核维修人员的请假信息,住户可以申请维修,可以对维修结果评价,维修人员负责住户提交的维修信息,也可以请假。公寓报修管理系统的开发根据操作人员需要设计的界面简洁美观,在功能模块布局上跟同类型网站保持一致,程序在实现基本要求功能时,也为数据信息面临的安全问题提供了一些实用的解决方案。可以说该程序在帮助管理者高效率地处理工作事务的同时,也实现了数据信息的整体化,规范化与自动化。 关键词:公寓报修管理系统;Spring Boot框架;MySQL;自动化;VUE
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值