BZOJ 1208 [HNOI 2004] 宠物收养所 Splay

Description

最近,阿Q开了一间宠物收养所。收养所提供两种服务:收养被主人遗弃的宠物和让新的主人领养这些宠物。每个领养者都希望领养到自己满意的宠物,阿Q根据领养者的要求通过他自己发明的一个特殊的公式,得出该领养者希望领养的宠物的特点值a(a是一个正整数,a<2^31),而他也给每个处在收养所的宠物一个特点值。这样他就能够很方便的处理整个领养宠物的过程了,宠物收养所总是会有两种情况发生:被遗弃的宠物过多或者是想要收养宠物的人太多,而宠物太少。 1.被遗弃的宠物过多时,假若到来一个领养者,这个领养者希望领养的宠物的特点值为a,那么它将会领养一只目前未被领养的宠物中特点值最接近a的一只宠物。(任何两只宠物的特点值都不可能是相同的,任何两个领养者的希望领养宠物的特点值也不可能是一样的)如果有两只满足要求的宠物,即存在两只宠物他们的特点值分别为a-b和a+b,那么领养者将会领养特点值为a-b的那只宠物。2.收养宠物的人过多,假若到来一只被收养的宠物,那么哪个领养者能够领养它呢?能够领养它的领养者,是那个希望被领养宠物的特点值最接近该宠物特点值的领养者,如果该宠物的特点值为a,存在两个领养者他们希望领养宠物的特点值分别为a-b和a+b,那么特点值为a-b的那个领养者将成功领养该宠物。一个领养者领养了一个特点值为a的宠物,而它本身希望领养的宠物的特点值为b,那么这个领养者的不满意程度为abs(a-b)。【任务描述】你得到了一年当中,领养者和被收养宠物到来收养所的情况,希望你计算所有收养了宠物的领养者的不满意程度的总和。这一年初始时,收养所里面既没有宠物,也没有领养者。

Input

第一行为一个正整数n,n<=80000,表示一年当中来到收养所的宠物和领养者的总数。接下来的n行,按到来时间的先后顺序描述了一年当中来到收养所的宠物和领养者的情况。每行有两个正整数a, b,其中a=0表示宠物,a=1表示领养者,b表示宠物的特点值或是领养者希望领养宠物的特点值。(同一时间呆在收养所中的,要么全是宠物,要么全是领养者,这些宠物和领养者的个数不会超过10000个)

Output

仅有一个正整数,表示一年当中所有收养了宠物的领养者的不满意程度的总和mod 1000000以后的结果。

Sample Input

5
0 2
0 4
1 3
1 2
1 5

Sample Output

3

(abs(3-2) + abs(2-4)=3,最后一个领养者没有宠物可以领养)

如标题所说是一颗普通的平衡树,只需插入一个数,查询前驱、后继,然后删除。

#include <iostream>
#include <cstdio>
#include<algorithm>
using namespace  std;
typedef long long LL;
const int SZ = 1000010;
const int INF = 1000000010;
const int MOD = 1000000;

struct node
{
    node *ch[2], *f;
    int sz, cnt, v;

    void maintain()
    {
        sz = cnt + ch[0] -> sz + ch[1] -> sz;
    }

    int cmp(int x)
    {
        if(x == v)  return -1;
        return x < v ? 0 : 1;
    }

    int dir()
    {
        return f -> ch[1] == this;
    }

    void setc(node *x, int d)
    {
        (ch[d] = x) -> f= this;
    }

}T[SZ], *root, *null;

int Tcnt;

node *newnode(int x, node *f)
{
    node *k = T + (++ Tcnt);
    k -> v = x;
    k -> ch[0] = k -> ch[1] = null;
    k -> sz = k -> cnt = 1;
    k -> f = f;
    return k;
}

void rotate(node *p)
{
    node *fa = p -> f;
    int d = p -> dir();
    fa -> f -> setc(p, fa -> dir());
    fa -> setc(p -> ch[d ^ 1], d); fa -> maintain();
    p -> setc(fa, d ^ 1); p -> maintain();
    if(fa == root) root = p;
}

void splay(node *p, node *rt = null)
{
    while(p -> f != rt)
    {
        if(p ->f -> f == rt)
            rotate(p);
        else
        {
            if(p -> dir() == p -> f -> dir())
                rotate(p -> f), rotate(p);
            else
                rotate(p), rotate(p);
        }
    }
    p -> maintain();
}

void insert(node *p, int x)
{
    if(root == null)
    {
        root = newnode(x, null);
        return ;
    }
    while(p != null)
    {
        p -> sz ++;
        int d = p -> cmp(x);
        if(d == -1)
        {
            p -> cnt ++;
            return ;
        }
        if(p -> ch[d] == null)
        {
            p -> ch[d] = newnode(x, p);
            p = p -> ch[d];
            break;
        }
        p = p -> ch[d];
    }
    splay(p);
}

void erase(node *p, int x)
{
    while(p != null)
    {
        p -> sz --;
        int d = p -> cmp(x);
        if(d == -1)
        {
            p -> cnt --;
            break;
        }
        p = p -> ch[d];
    }
    if(p -> cnt)
        return ;
    splay(p);
    if(p -> ch[0] == null)
    {
        root = p -> ch[1];
        root -> f = null;
        return ;
    }
    if(p -> ch[1] == null)
    {
        root = p -> ch[0];
        root -> f = null;
        return ;
    }
    p = p -> ch[0];
    while(p -> ch[1] != null)
        p = p -> ch[1];
    splay(p, root);
    p -> ch[1] = root -> ch[1];
    p -> ch[1] -> f = p;
    p -> f = null; p -> maintain();
    root = p;
}

void init()
{
    null = newnode(-INF, null);
    null -> sz = null -> cnt = 0;
    root = null;
}

int ask_pre(node *p, int x)
{
    int ans = INF;
    while(p != null)
    {
        if(p -> v <= x)
            ans = p -> v, p = p -> ch[1];
        else
            p = p -> ch[0];
    }
    return ans;
}

int ask_suf(node *p, int x)
{
    int ans = INF;
    while(p != null)
    {
        if(p -> v >= x)
            ans  = p -> v, p = p -> ch[0];
        else
            p = p -> ch[1];
    }
    return ans;
}

int main()
{
    init();
    int n;
    LL ans = 0;
    bool haha = 0;
    int dq = 1;
    scanf("%d", &n);
    while(n --)
    {
        int kind, num;
        scanf("%d%d", &kind, &num);
        if(kind)
        {
            if(!root -> sz || haha)
            {   
                haha = 1;
                insert(root, num);
            }
            else if(root -> sz && !haha)
            {
                int pre = ask_pre(root, num);
                int suf = ask_suf(root, num);
                if(abs(num - pre) <= abs(suf - num))
                {
                    ans = ((ans % MOD) + (abs(num - pre)) % MOD) % MOD;
                    erase(root, pre);       
                }
                else if(abs(num - pre) > abs(suf - num))
                {
                    ans = ((ans % MOD) + (abs(suf - num)) % MOD) % MOD;
                    erase(root, suf);               
                }
            }
        }
        else
        {
            if(!root -> sz || !haha)
            {
                insert(root, num);
                haha = 0;
            }
            else if(root -> sz && haha)
            {
                int pre = ask_pre(root, num);
                int suf = ask_suf(root, num);               
                if(abs(num - pre) <= abs(suf - num))
                {
                    ans = ((ans % MOD) + (abs(num - pre) % MOD)) % MOD;
                    erase(root, pre);               
                }
                else if(abs(num - pre) > abs(num - suf))
                {
                    ans = ((ans % MOD) + (abs(num - suf) % MOD)) % MOD;
                    erase(root, suf);               
                }
            }
        }
    }
    printf("%lld", ans % MOD);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值