弱校胡策 POJ2709 Painter(贪心)

Description
The local toy store sells small fingerpainting kits with between three and twelve 50ml bottles of paint, each a different color. The paints are bright and fun to work with, and have the useful property that if you mix X ml each of any three different colors, you get X ml of gray. (The paints are thick and “airy”, almost like cake frosting, and when you mix them together the volume doesn’t increase, the paint just gets more dense.) None of the individual colors are gray; the only way to get gray is by mixing exactly three distinct colors, but it doesn’t matter which three. Your friend Emily is an elementary school teacher and every Friday she does a fingerpainting project with her class. Given the number of different colors needed, the amount of each color, and the amount of gray, your job is to calculate the number of kits needed for her class.
Input
The input consists of one or more test cases, followed by a line containing only zero that signals the end of the input. Each test case consists of a single line of five or more integers, which are separated by a space. The first integer N is the number of different colors (3 <= N <= 12). Following that are N different nonnegative integers, each at most 1,000, that specify the amount of each color needed. Last is a nonnegative integer G <= 1,000 that specifies the amount of gray needed. All quantities are in ml.
Output
For each test case, output the smallest number of fingerpainting kits sufficient to provide the required amounts of all the colors and gray. Note that all grays are considered equal, so in order to find the minimum number of kits for a test case you may need to make grays using different combinations of three distinct colors.
Sample Input
3 40 95 21 0
7 25 60 400 250 0 60 0 500
4 90 95 75 95 10
4 90 95 75 95 11
5 0 0 0 0 0 333
0
Sample Output
2
8
2
3
4

题目翻译:
杂货店出售一种由 N(3<=N<=12)种不同颜色的颜料,每种一瓶(50ML),组成的颜料套装。你现在需要使用这 N 种颜料;不但如此,你还需要一定数量的灰色颜料。杂货店从来不出售灰色颜料——也就是它不属于这 N 种之一。幸运的是,灰色颜料是比较好配置的,如果你取出三种不同颜色的颜料各 x ml,混合起来就可以得到 xml 的灰色颜料(注意不是 3x)。现在,你知道每种颜料各需要多少 ml。你决定买尽可能少的“颜料套装”,来满足你需要的这 N+1 种颜料。那么你最少需要买多少个套装呢?
输入描述
输入包含若干组测试数据。每组数据一行:第一个数 N, 3<=N<=12, 含义如上;接下来 N+1 个数,分别表示你需要的 N+1 种颜料的毫升数。最后一种是灰色。所有输入的毫升数<=1000.
注意:输入中不存在每个颜料套装的毫升数。由题意可知,每种各 50ml,即一共 50N ml
输出描述
每组数据输出一行,最少需要的套装数。

正解:先找到所需要的最多的颜料,因为买一次就要买一套,然后求出剩下的颜料。每次让最大的三个分别-1,直到第三个变成0然后ans+1,所有的颜料都+50,暴力修改。这题难想主要是在这个要每次-1。这样暴力的做就可以了。

emmmm…具体代码实现的话可以用堆来维护,也可以每次sort,因为n是1000,所以复杂度蛮够的。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn=105;
int need[maxn],sheng[maxn];
bool cmp(int a,int b)
{
    return a>b;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        for(int i=1;i<=n;i++)
            scanf("%d",&need[i]);
        scanf("%d",&hui);
        sort(need+1,need+n+1,cmp);
        int cnt=need[1]/50+1;
        if(need[1]%50==0)
            cnt-=1;
        for(int i=1;i<=n;i++)
            sheng[i]=50*cnt-need[i];
        sort(sheng+1,sheng+n+1,cmp);
        while(hui>0)
        {
            if(sheng[3]==0)
            {
                cnt++;
                for(int i=1;i<=n;i++)
                    sheng[i]+=50;
            }
            sheng[1]--;
            sheng[2]--;
            sheng[3]--;
            hui--;
            sort(sheng+1,sheng+n+1,cmp);
        }
        printf("%d\n",cnt);     
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值