Wireless Network

Problem description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have

set up a wireless network with the lap computers, but an unexpected aftershock attacked, all

computers in the network were all broken. The computers are repaired one by one, and the

network gradually began to work again. Because of the hardware restricts, each computer can

only directly communicate with the computers that are not farther than d meters from it. But

every computer can be regarded as the intermediary of the communication between two

other computers, that is to say computer A and computer B can communicate if computer A

and computer B can communicate directly or there is a computer C that can communicate

with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every

moment, repairing a computer, or testing if two computers can communicate. Your job is to

answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the

number of computers, which are numbered from 1 to N, and D is the maximum distance two

computers can communicate directly. In the next N lines, each contains two integers xi, yi (0

<= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end

of input, there are operations, which are carried out one by one. Each line contains an

operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or

“FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Algorithm

Disjoint Set Union

Code

#include<cstdio>
#include<iostream>
#define inf 1e9f
using namespace std;
struct edge
{
	int x,y;
}p[10010];
int n,m,d;
int fa[10010];
int dis[1010][1010];
bool vis[1010];
int find(int a)
{
	while(a!=fa[a])a=fa[a];
	return a;
}
void merge(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		fa[fy]=fx;
	}
}
int main()
{
	scanf("%d%d",&n,&d);
	for(int i=1;i<=n;i++) fa[i]=i,scanf("%d%d",&p[i].x,&p[i].y);
	
	for(int i=1;i<=n;i++)
	 for(int j=1;j<=n;j++)
	 {
	 	if(i!=j)
	 	{
	 		int dist=(p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y);
	 		if(dist>d*d)dis[i][j]=dis[j][i]=inf;
	 		else dis[j][i]=dis[i][j]=dist;
	 	}
	 }
	//for(int i=1;i<=n;i++){for(int j=1;j<=n;j++)cout<<i<<"->"<<j<<":"<<dis[i][j]<<endl;}
	char a;
	while(cin>>a)
	{
		int x,y;
		if(a=='O')
		{
			scanf("%d",&x);
			vis[x]=1;
			for(int i=1;i<=n;i++)
				if(vis[i]==1&&i!=x&&dis[i][x]<=d*d)merge(i,x);
		}
		if(a=='S')
		{
			scanf("%d%d",&x,&y);
			int fx=find(x),fy=find(y);
			if(fx==fy)printf("SUCCESS\n");
			else printf("FAIL\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值