String Builder

You are going to read four numbers: n, a, b and c, like this:

12 2 5 3

First, n is used to build up a string from 0 to n, like this:

0123456789101112

is a string build up for n=12.

Then, in all the digits from index a to index b, count the appearence of c.

For the string above, 2 5 is:

2345

Thus the appearence of 3 is 1.

Input Format:

Four positive numbers, nab and c, where a<b<n<10000, and 0<=c<=9..

Output Format:

One number represnets the length of the generated string. One number represents the apprence of c. There is a space between the two numbers.

Sample Input:

12 2 5 3

结尾无空行

Sample Output:

16 1

结尾无空行

代码如下

#include<stdio.h>
#include<vector>
using namespace std;
int main()
{
    int n,a,b,c;
    scanf("%d %d %d %d",&n,&a,&b,&c);
    int j=0,l=0,sum=0;
    for(int i=0;i<=n;i++)
    {
        if(!i)//特判0是不是满足条件
        {
            if(a==0&&c==0)
                sum++;
            l++;
            continue;
        }
        j=i;
        vector<int> v;
        while(j)//将数分成1个个0-9的数
        {
            v.push_back(j%10);
            j/=10;
        }
        for(int j=v.size()-1; j>=0; j--)//记录c在a-b位置出现的次数
        {
            if(l>=a&&l<=b&&v[j]==c)
                sum++;
            l++;
        }
    }
    printf("%d %d",l,sum);//输出长度和总数
    return 0;
}

emmm,比赛时,吃了英语的亏

这篇文章以互相学习为主,有什么错的还望告知,谢谢啦

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值