This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
#include <iostream>
#include <vector>
using namespace std;
int main(){
int ka,kb;
vector<pair<int,double> > a,b,sum;
cin>>ka;
int tmp=ka;
int c;
double d;
while(tmp--){
cin>>c>>d;
a.push_back(make_pair(c,d));//多项式a
}
cin>>kb;
tmp=kb;
while(tmp--){
cin>>c>>d;
b.push_back(make_pair(c,d));//多项式b
}
int count=0,ia=0,ib=0;
while(ia<ka&&ib<kb){
if(a[ia].first > b[ib].first)
sum.push_back(a[ia++]);
else if(a[ia].first < b[ib].first)
sum.push_back(b[ib++]);
else{//同类项,相加
double t=a[ia].second+b[ib].second;
if(t!=0)//将系数不为0的项压入sum
sum.push_back(make_pair(a[ia].first,a[ia].second+b[ib].second));
ia++;
ib++;
}
}
while(ia<ka)
sum.push_back(a[ia++]);
while(ib<kb)
sum.push_back(b[ib++]);
int n=sum.size();
cout<<n;
for(int i=0;i<n;i++)
printf(" %d %0.1f",sum[i].first,sum[i].second);
return 0;
}