1002.A+B for Polynomials (25) 合并同类项

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int ka,kb;
    vector<pair<int,double> > a,b,sum;
    cin>>ka;
    int tmp=ka;
    int c;
    double d;
    while(tmp--){
        cin>>c>>d;
        a.push_back(make_pair(c,d));//多项式a
    }
    cin>>kb;
    tmp=kb;
    while(tmp--){
        cin>>c>>d;
        b.push_back(make_pair(c,d));//多项式b
    }

    int count=0,ia=0,ib=0;
    while(ia<ka&&ib<kb){
        if(a[ia].first > b[ib].first)
            sum.push_back(a[ia++]);
        else if(a[ia].first < b[ib].first)
            sum.push_back(b[ib++]);
        else{//同类项,相加
            double t=a[ia].second+b[ib].second;
            if(t!=0)//将系数不为0的项压入sum
                sum.push_back(make_pair(a[ia].first,a[ia].second+b[ib].second));
            ia++;
            ib++;
        }
    }
    while(ia<ka)
        sum.push_back(a[ia++]);
    while(ib<kb)
        sum.push_back(b[ib++]);
    int n=sum.size();
    cout<<n;
    for(int i=0;i<n;i++)
        printf(" %d %0.1f",sum[i].first,sum[i].second);
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值