TOJ 2746: Classifying Triangles

2746: Classifying Triangles

描述

A triangle can be described by the lengths of its three sides.  However, any given three lengths will not necessarily describe a triangle.  In this problem, you must determine the type of triangle, given three side lengths.

输入

The first line of input will contain a positive integer T < 1000, where T denotes the number of test cases.  Each of the next T lines will contain three positive integers.  Each integer will be less than 10^9.

输出

For each case of the input there will be one line of output.  It will be formatted as:
Case #{x}: {triangle type}
where x denotes the case number being processed and {triangle type} is the type of the triangle.  {triangle type} will be one of the following, depending on the values of the three sides:
Invalid - The three sides cannot form a triangle
Equilateral  - All three sides of valid triangle are equal
Isosceles  - Exactly two of the sides of a valid triangle are equal
Scalene - No pair of sides are equal in a valid triangle.

样例输入

5
1 2 5
1 1 1
4 4 2
3 4 5
1 1 2

样例输出

Case 1: Invalid
Case 2: Equilateral
Case 3: Isosceles
Case 4: Scalene
Case 5: Invalid

代码

#include <stdio.h>
int main()
{
int n,i,a,b,c;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d%d",&a,&b,&c);
if((a+b<=c)||(a+c<=b)||(b+c<=a)||(a<0)||(b<0)||(c<0))
printf("Case %d: Invalid\n",i+1);
else
{
if(a==b&&b==c)
printf("Case %d: Equilateral\n",i+1);
else if(a==b||b==c||a==c)
printf("Case %d: Isosceles\n",i+1);
else
printf("Case %d: Scalene\n",i+1);
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值