TOJ5002:May Day Holiday

题目链接: [May Day Holiday]

描述

As a university advocating self-learning and work-rest balance, Marjar University has so many days of rest, including holidays and weekends. Each weekend, which consists of Saturday and Sunday, is a rest time in the Marjar University.

The May Day, also known as International Workers' Day or International Labour Day, falls on May 1st. In Marjar University, the May Day holiday is a five-day vacation from May 1st to May 5th. Due to Saturday or Sunday may be adjacent to the May Day holiday, the continuous vacation may be as long as nine days in reality. For example, the May Day in 2015 is Friday so the continuous vacation is only 5 days (May 1st to May 5th). And the May Day in 2016 is Sunday so the continuous vacation is 6 days (April 30th to May 5th). In 2017, the May Day is Monday so the vacation is 9 days (April 29th to May 7th). How excited!

Edward, the headmaster of Marjar University, is very curious how long is the continuous vacation containing May Day in different years. Can you help him?

输入

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case, there is an integer y (1928 <= y <= 9999) in one line, indicating the year of Edward's query.

输出

For each case, print the number of days of the continuous vacation in that year.

样例输入

3
2015
2016
2017
 

样例输出

5
6
9
题意

给出一个年份,输出五一劳动节可以放多长时间假期,计算规则是如果是周一,那么加上两端的周末,一共是9天,就是说,从5月1号开始到5月5号是一定放假的,如果有周末交集那么取最大值。年份取值[1928,9999] 。首先判断闰年,最基础的方式。

题目来自浙江省2015年acm省赛,也是各大oj平台上的存录的题。

分析过程:

  • 初始化变量t(测试用例的数量),d(表示星期几的偏移量,从2开始),yn
  • 数组a表示从星期一开始的各个月份的天数偏移。
  • 循环从1928年开始,计算直到9999年的每一天的星期偏移,并将结果存储在数组p中。
  • 如果是闰年,则d再加1。
  • 如果d等于8或9,则重置d为1或2,因为数组a只有7个元素,一周也只有七天。

附上AC代码: 

#include<bits/stdc++.h>
using namespace std;
int p[10000];
int run(int x)
{
	if(x % 400 == 0 || x%4==0&& x%100!= 0)
	{
		return 1;
	}
	return 0;
}
int main()
{
	int t,d=2,y,n;
	int a[8]={0,9,6,5,5,5,5,6};
	for(int i=1928;i<=9999;i++)
	{
		p[i]=a[d];
		d++;
		if(run(i+1)==1)d++;
		if(d==8)d=1;
		if(d==9)d=2;
	}
	cin>>t;
	while(t--)
	{
		cin>>n;
		cout<<p[n]<<endl;
	}
	return 0;
}

  • 9
    点赞
  • 25
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值