HDU 3549 Flow Problem 最大流模板题

47 篇文章 0 订阅
10 篇文章 0 订阅
Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 13561    Accepted Submission(s): 6482


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.


Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)


Output
For each test cases, you should output the maximum flow from source 1 to sink N.


Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1


Sample Output
Case 1: 1
Case 2: 2
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>
//#define CHECK_TIME

const int N=15; //最大点数

struct edge{//终点 容量 反向边在G[to]中的下标
    int to,cap,rev;
};
vector<edge>G[N+1];
bool used[N+1];

inline void add_edge(int fr,int to,int cap){//添加一条从fr到to容量为cap的边
    G[fr].push_back({to,cap,G[to].size()});
    G[to].push_back({fr,0,G[fr].size()-1});
}

int dfs(int v,int t,int f){
    if(v==t)
        return f;
    used[v]=true;
    for(int i=0;i<G[v].size();++i){
        edge&e=G[v][i];
        if(used[e.to]==false&&e.cap>0){
            int d=dfs(e.to,t,min(f,e.cap));
            if(d>0){
                e.cap-=d;
                G[e.to][e.rev].cap+=d;//给反向边增加流量
                return d;
            }
        }
    }
    return 0;
}

int max_flow(int s,int t){//s源点 t汇点
    int flow=0;
    while(true){
        fill(used,used+N+1,false);
        int f=dfs(s,t,INF);
        if(f==0)
            return flow;
        flow+=f;
    }
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);
    int T,n,m,fr,to,cap;
    scanf("%d",&T);
    for(int t=1;t<=T;++t){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
            G[i].clear();
        while(m--){
            scanf("%d%d%d",&fr,&to,&cap);
            add_edge(fr,to,cap);
        }
        printf("Case %d: %d\n",t,max_flow(1,n));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值