HDU Mr. Frog’s Game 2016CCPC东北地区大学生程序设计竞赛 - 重现赛

Mr. Frog’s Game
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
One day, Mr. Frog is playing Link Game (Lian Lian Kan in Chinese).



In this game, if you can draw at most three horizontal or vertical head-and-tail-connected lines over the empty grids(the lines can be out of the whole board) to connect two non-empty grids with the same symbol or the two non-empty grids with the same symbol are adjacent, then you can change these two grids into empty and get several more seconds to continue the game.

Now, Mr. Frog starts a new game (that means there is no empty grid in the board). If there are no pair of grids that can be removed together,Mr. Frog will say ”I’m angry” and criticize you.

Mr. Frog is battle-scarred and has seen many things, so he can check the board in a very short time, maybe one second. As a Hong Kong Journalist, what you should do is to check the board more quickly than him, and then you can get out of the room before Mr. Frog being angry.


Input
The first line contains only one integer T (T≤500), which indicates the number of test cases.

For each test case, the first line contains two integers n and m (1≤n,m≤30).

In the next n lines, each line contains m integers,  j-th number in the i-th line means the symbol on the grid(the same number means the same symbol on the grid).


Output
For each test case, there should be one line in the output.

You should output “Case #x: y”,where x is the case number(starting from 1), and y is a string representing the answer of the question. If there are at least one pair of grids that can be removed together, the y is “Yes”(without quote), else y is “No”.


Sample Input

2
3 3
1 2 1
2 1 2
1 2 1
3 3
1 2 3
2 1 2
3 2 1



Sample Output

Case #1: Yes
Case #2: No

Hint

first sample can be explained as below.

这里写图片描述
连连看 不难发现
一个砖块的上下左右相邻的砖块是相同的
或者 最左/右一列 或者最上/下一行 有2个砖块相同 才可以消去

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007
#define pll pair<ll,ll>
#define pid pair<int,double>
//#define CHECK_TIME

int dir[4][2]={
    {0,-1},{0,1},
    {-1,0},{1,0}
};

int mp[30][30];

bool check(int n,int m){
    for(int i=0;i<m;++i)
        for(int j=i+1;j<m;++j){
            if(mp[0][i]==mp[0][j])
                return true;
            if(mp[n-1][i]==mp[n-1][j])
                return true;
        }
    for(int i=0;i<n;++i)
        for(int j=i+1;j<n;++j){
            if(mp[i][0]==mp[j][0])
                return true;
            if(mp[i][m-1]==mp[j][m-1])
                return true;
        }
    for(int i=0;i<n;++i)
        for(int j=0;j<m;++j)
            for(int k=0;k<4;++k){
                int ni=i+dir[k][0],nj=j+dir[k][1];
                if(ni>0&&ni<n&&nj>0&&nj<m)
                    if(mp[ni][nj]==mp[i][j])
                        return true;
            }
    return false;
}

int main()
{
    //freopen("/home/lu/文档/r.txt","r",stdin);
    //freopen("/home/lu/文档/w.txt","w",stdout);

    int T,n,m;
    scanf("%d",&T);
    for(int t=1;t<=T;++t){
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;++i)
            for(int j=0;j<m;++j)
                scanf("%d",&mp[i][j]);
        cout<<"Case #"<<t<<": "<<(check(n,m)?"Yes":"No")<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值