HDU2971 Tower 【矩阵快速幂】

Tower

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2862    Accepted Submission(s): 686


Problem Description
Alan loves to construct the towers of building bricks. His towers consist of many cuboids with square base. All cuboids have the same height h = 1. Alan puts the consecutive cuboids one over another:

Recently in math class, the concept of volume was introduced to Alan. Consequently, he wants to compute the volume of his tower now. The lengths of cuboids bases (from top to bottom) are constructed by Alan in the following way:

1. Length a1 of the first square is one.

2. Next, Alan fixes the length a2 of the second square.

3. Next, Alan calculates the length an (n > 2) by 2*a2*(an-1)-(an-2). Do not ask why he chose such

a formula; let us just say that he is a really peculiar young fellow. For example, if Alan fixes a2 = 2, then a3 = 8 -a1 = 7; see Figure 1. If Alan fixes a2 = 1, then an = 1 holds for all n belong to N; see Figure 2.

Now Alan wonders if he can calculate the volume of tower of N consecutive building bricks. Help Alan and write the program that computes this volume. Since it can be quite large, it is enough to compute the answer modulo given natural number m.
 

Input
The input contains several test cases. The first line contains the number t (t <= 10^5) denoting the number of test cases. Then t test cases follow. Each of them is given in a separate line containing three integers a2,N,m (1 <= a2,m <= 10^9, 2 <= N <= 10^9) separated by a single space, where a2 denotes the fixed length of second square in step 2, while N denotes the number of bricks constructed by Alan.
 

Output
For each test case (a2,N,m) compute the volume of tower of N consecutive bricks constructed by Alan according to steps (1-3) and output its remainder modulo m.
 

Sample Input
  
  
3 2 3 100 1 4 1000 3 3 1000000000
 

Sample Output
  
  
54 4 299
Hint
 

Source
 

卡常....各种TLE

减少取模次数才能过

令p=2*a2;

a[n] = p * a[n-1] - a[n-2]

①:a[n]^2 = (p * a[n-1])^2 + a[n-2]^2 - 2*p*a[n-1]*a[n-2]

②:v[n] = v[n-1] + a[n]^2

2*p*a[n]*a[n-1] = 2*p*( p*a[n-1] - a[n-2] ) * a[n-1]

③:2*p*a[n]*a[n-1] = 2*(p*a[n-1])^2 - 2*p*a[n-1]*a[n-2]


于是构造一个4*4矩阵即可


#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<ctime>
#include<string.h>
#include<math.h>
#include<list>

using namespace std;

#define ll long long
#define pii pair<int,int>

const int inf=1e9+7;
const int INF=inf;
const double EPS=1e-8;

ll MOD=inf;

struct Matrix{
    const static int MAXN=4;
    ll m[MAXN][MAXN];

    void init0(){
        for(int i=0;i<MAXN;++i){
            fill(m[i],m[i]+MAXN,0);
        }
    }

    void initE(){//初始化为单位矩阵
        for(int i=0;i<MAXN;++i){
            for(int j=0;j<MAXN;++j){
                m[i][j]=(i==j);
            }
        }
    }

    ll* operator[](std::size_t n){
        return m[n];
    }

    const ll* operator[](std::size_t n)const{
        return m[n];
    }

    Matrix operator*(const Matrix&x){
        Matrix ans;
        for(int i=0;i<MAXN;++i){
            for(int j=0;j<MAXN;++j){
                ans[i][j]=0;
                for(int k=0;k<MAXN;++k){
                    ans[i][j]=(ans[i][j]+m[i][k]*x[k][j])%MOD;
                }
            }
        }
        return ans;
    }

    Matrix operator^(ll n){
        Matrix ans;
        ans.initE();
        Matrix t=*this;
        while(n){
            if(n&1){
                ans=ans*t;
            }
            t=t*t;
            n>>=1;
        }
        return ans;
    }
}mat1,mat2;

void init(ll a2){
    ll p=(2*a2)%MOD;
    mat1.init0();
    mat2.init0();

    mat2[0][0]=mat2[0][2]=mat2[1][2]=mat2[2][1]=1;
    mat2[0][1]=mat2[1][1]=(p*p)%MOD;
    mat2[3][1]=(2*p*p)%MOD;
    mat2[0][3]=mat2[1][3]=mat2[3][3]=-1+MOD;

    mat1[0][0]=(1+a2*a2)%MOD;
    mat1[1][0]=(a2*a2)%MOD;
    mat1[2][0]=1;
    mat1[3][0]=(2*p*a2)%MOD;
}

int main()
{
    //freopen("/home/lu/Documents/r.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--){
        ll a2,n;
        scanf("%lld%lld%lld",&a2,&n,&MOD);

        init(a2);
        mat2=mat2^(n-2);

        int ans=(mat2*mat1)[0][0];
        ans=(ans%MOD+MOD)%MOD;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值