POJ 2378 Tree Cutting

题目链接

Tree Cutting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5866 Accepted: 3558

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N.

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS:

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

 

给一棵树,去除一个点后分成几块,要求每一块不超过所有点数量的一半。

去除一个点后,它的每个子节点成一块,他的父亲节点成一块。

那么就在dfs的时候,每一棵儿子节点的子树和判断一下是否超过n/2;然后累和+1(自身)就是自己的子数和,n-自己的子数和,就是父亲块的节点数量,判断是否超过n/2即可。

这压根就不是树形dp吧。。。为什么辅导书把它放在树形dp呢。。。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int N=1e4+10;
vector<int>tr[N];
int ans[N],cnt,n;
int dfs(int x,int fa)
{
	int sum=1;
	bool f=0;
	for(int i=0;i<tr[x].size();i++)
	{
		int v=tr[x][i];
		if(v==fa) continue;
		int t=dfs(v,x);
		if(t>n/2) f=1;
		sum+=t;
	}
	if(n-sum>n/2)
		f=1;
	if(!f)
		ans[cnt++]=x;
//	cout<<x<<' '<<sum<<endl;
	return sum;
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	cin>>n;
	int x,y;
	for(int i=1;i<n;i++)
	{
		cin>>x>>y;
		tr[x].push_back(y);
		tr[y].push_back(x);
	}
	cnt=0;
	dfs(1,0);
	if(cnt==0)
		cout<<"NONE"<<endl;
	else
	{
		sort(ans,ans+cnt);
		for(int i=0;i<cnt;i++)
			cout<<ans[i]<<endl;
	}
		
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值