HDU3586 Information Disturbing 树形dp+二分

题目链接

Information Disturbing

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5602    Accepted Submission(s): 1811


 

Problem Description

In the battlefield , an effective way to defeat enemies is to break their communication system.
The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all of their soldiers. Information can exchange between any two soldiers by the communication routes. The number 1 soldier is the total commander and other soldiers who have only one neighbour is the frontline soldier.
Your boss zzn ordered you to cut off some routes to make any frontline soldiers in the network cannot reflect the information they collect from the battlefield to the total commander( number 1 soldier).
There is a kind of device who can choose some routes to cut off . But the cost (w) of any route you choose to cut off can’t be more than the device’s upper limit power. And the sum of the cost can’t be more than the device’s life m.
Now please minimize the upper limit power of your device to finish your task.

 

 

Input

The input consists of several test cases.
The first line of each test case contains 2 integers: n(n<=1000)m(m<=1000000).
Each of the following N-1 lines is of the form:
ai bi wi
It means there’s one route from ai to bi(undirected) and it takes wi cost to cut off the route with the device.
(1<=ai,bi<=n,1<=wi<=1000)
The input ends with n=m=0.

 

 

Output

Each case should output one integer, the minimal possible upper limit power of your device to finish your task.
If there is no way to finish the task, output -1.

 

 

Sample Input

 

5 5 1 3 2 1 4 3 3 5 5 4 2 6 0 0

 

 

Sample Output

 

3

 

最大边的最小值,二分;

dp[u]表示切断u子树里所有叶子节点的最小花费(切的每一条边不超过mid的时候),从儿子节点向父亲节点即从下向上转移;

设v是u的儿子节点,切除u每一个儿子v的所有叶子节点有两种方案,一种是切断uv之间的边,一种是按照v的方案;如果u,v之间边权大于mid,只能按照v的方案;如果边权小于mid,则取min。

听不懂就看代码吧,简单易懂。

 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#define LL long long
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;
const int N=1e3+10; 
struct node
{
	int v,w;
	node (){}
	node(int v,int w):v(v),w(w){}	
};
vector<node>tr[N];
int n,m,l,r,ans,mid,dp[N];
void dfs(int u,int fa)
{
	if(tr[u].size()==1&&u!=1)
		dp[u]=m+1;//叶子节点初始化
	else
		dp[u]=0;//非叶子节点初始化
	for(int i=0;i<tr[u].size();i++)
	{
		int v=tr[u][i].v,w=tr[u][i].w;
		if(v==fa) continue;
		dfs(v,u);
		if(w>mid)//边权大于mid不能选用
			dp[u]+=dp[v];
		else
			dp[u]+=min(w,dp[v]);//选取一个最小值
	}
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	while(cin>>n>>m,n+m)
	{
		r=0;
		int u,v,w;
		for(int i=1;i<=n;i++)
			tr[i].clear();
		for(int i=1;i<n;i++)
		{
			cin>>u>>v>>w;
			tr[u].push_back(node(v,w));
			tr[v].push_back(node(u,w));
			r=max(r,w);//右边界
		}
		l=1,ans=-1;//没有答案输出-1,所以ans初始化-1
		while(l<=r)//二分
		{
			mid=(l+r)>>1;
			dfs(1,0); 
			if(dp[1]<=m)
			{
				ans=mid;
				r=mid-1;
			}
			else
				l=mid+1;
		}
		cout<<ans<<'\n';
	}
}
wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值