FZU 1650 1752 a^b mod

Problem 1752 A^B mod C

Accept: 837    Submit: 3615
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

 Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

 Output

For each testcase, output an integer, denotes the result of A^B mod C.

 Sample Input

3 2 42 10 1000

 Sample Output

124

 Source

FZU 2009 Summer Training IV--Number Theory

题解:

大数据处理,次方用乘法,乘法用加法,保证不爆。

#include<stdio.h>
#define ll unsigned __int64
ll mul(ll a,ll b,ll c)
{
	ll tmp=a%c,tre=0;
	while(b)
	{
		if(b&1)
			if((tre+=tmp)>=c)
			   tre-=c; 
        if((tmp<<=1)>=c)
            tmp-=c;
        b>>=1;
	}
	return tre;
}
ll mod(ll a,ll b,ll c)
{
	ll y=1;
	a=a%c;
	while(b)
	{
		if(b&1)
		    y=mul(y,a,c);
        a=mul(a,a,c);
        b>>=1;
	}
	return y;
}
int main()
{
	ll a,b,c;
	while(~scanf("%I64u%I64u%I64u",&a,&b,&c))
	{
		printf("%I64u\n",mod(a,b,c));
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值