A^B mod C (快速幂+快速乘+取模)题解

A^B mod C

Given A,B,C, You should quickly calculate the result of A^B mod C. (1<=A,B,C<2^63).

Input

There are multiply testcases. Each testcase, there is one line contains three integers A, B and C, separated by a single space.

Output

For each testcase, output an integer, denotes the result of A^B mod C.

Sample Input
3 2 4
2 10 1000
Sample Output
1
24

我用的unsigned_int64开数据。用快速幂和快速乘写,注意:不要用%,会超时(大佬说的,并且我已经验证过了...233)

代码:

#include<stdio.h>
#define ull unsigned __int64
ull mul(ull a,ull b,ull c){  
    ull res=0;
    a=a%c;
    while(b){  
        if(b & 1)	res+=a;  
        if(res>=c)	res-=c;	//代替%
        b/=2;  
        a+=a;
        if(a>=c)  a-=c; 	//代替%
    }  
    return res;
}


int main(){
	ull a,b,c,ans;
	while(scanf("%I64u%I64u%I64u",&a,&b,&c)!=EOF){
		ans=1;
		a=a%c;
		while(b){
			if(b%2==1)	ans=mul(ans,a,c);
			a=mul(a,a,c);
			b/=2;
		}
		printf("%I64u\n",ans);
	} 
	return 0;
}



 

转载于:https://www.cnblogs.com/KirinSB/p/9409142.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值