(前缀表达式)poj3295 Tautology

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9307 Accepted: 3552

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source




这道题是明显的一道前缀表达式,题意是给你一条式子,判断它是否恒真。
五种操作符的意义如下:
Kwx:w and x
Awx:w or x
Nw:not w
Cwx:(not w) or x
Ewx:not (w xor x)

可以枚举5个变量的32种组合,计算表达式的值,如果出现假值,则可判断为非恒真命题。
前缀表达式的普遍做法是用栈存储操作数,读取到操作符弹出操作数进行操作,再将结果压栈。
这样最后栈顶的元素便是计算结果。

题目代码如下:

Memory 168K  Time 0MS

#include<stdio.h>
#include<stack>
using namespace std;

char WFF[105];
int p,q,r,s,t;
stack<int> n;

bool isVal(int i){
	if (WFF[i]=='p'){
		n.push(p);
		return true;
	}
	else if (WFF[i]=='q'){
		n.push(q);
		return true;
	}
	else if (WFF[i]=='r'){
		n.push(r);
		return true;
	}
	else if (WFF[i]=='s'){
		n.push(s);
		return true;
	}
	else if (WFF[i]=='t'){
		n.push(t);
		return true;
	}
	
	return false;
}

void oper(int i){
	int w,x;
	if (WFF[i]=='K'){
		w=n.top();
		n.pop();
		x=n.top();
		n.pop();
		n.push(w&x);
	}
	else if (WFF[i]=='A'){
		w=n.top();
		n.pop();
		x=n.top();
		n.pop();
		n.push(w|x);
	}
	else if (WFF[i]=='N'){
		w=n.top();
		n.pop();
		n.push(!w);
	}
	else if (WFF[i]=='C'){
		w=n.top();
		n.pop();
		x=n.top();
		n.pop();
		n.push(!w|x);
	}
	else if (WFF[i]=='E'){
		w=n.top();
		n.pop();
		x=n.top();
		n.pop();
		n.push(!(w^x));
	}
}

int main(){
	int l;
	bool flag;
	while(scanf("%s",WFF) && WFF[0]!='0'){
		l=strlen(WFF);
		flag=true;
		for (p=0;p<2;p++){
			for(q=0;q<2;q++){
				for(r=0;r<2;r++){
					for(s=0;s<2;s++){
						for(t=0;t<2;t++){
							for (int i=l-1;i>=0;i--){
								if (!isVal(i))
									oper(i);
							}
							int ans=n.top();
							n.pop();
							if (!ans){
								flag=false;
								break;
							}
						}
						if (!flag)
							break;
					}
					if (!flag)
						break;
				}
				if (!flag)
					break;
			}
			if (!flag)
				break;
		}

		if (flag)
			printf("tautology\n");
		else
			printf("not\n");
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值